Add Bluetooth-client-notification to test bluetooth pairing
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 Name:       notification-service
2 Summary:    Simple notification service
3 Version:    0.0.2
4 Release:    1
5 Group:      Application Framework/Notifications
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.bz2
8 BuildRequires: pkgconfig(eina) 
9 BuildRequires: pkgconfig(ecore) 
10 BuildRequires: pkgconfig(com-core) 
11 BuildRequires: pkgconfig(notification)
12 BuildRequires: dbus-devel
13 BuildRequires: pkgconfig(dbus-glib-1)
14 BuildRequires: bluetooth-frwk-devel
15 BuildRequires: bundle-devel
16
17 %description
18 Headless notification service that collects incoming notifications from the
19 the platform, maintains a database of active notifications, and broadcast updates
20 to all listeners.
21
22 %package test
23 Summary: Test clients for %{name}
24 Group:   Application Framework/Notifications
25 %description test
26 This package provides unit test used in the development of the notification service.
27
28 %prep
29 %setup -q -n %{name}-%{version}
30
31 %define PREFIX %{_prefix}/apps/
32
33 %build
34 %autogen
35 make %{?_smp_mflags}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %files
42 %defattr(-,root,root,-)
43 %{_bindir}/notification-service
44 %{_libdir}/systemd/system/notifications.service
45 %{_libdir}/systemd/system/notifications.socket
46 %{_libdir}/systemd/system/sockets.target.wants/notifications.socket
47
48 %files test
49 %defattr(-,root,root,-)
50 %{_bindir}/sample-display-client
51 %{_bindir}/send-notification
52 %{_bindir}/bluetooth_notification_client