d2e8b4d908d8d6fab6ef49649cec1549e2f34a48
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 Name:       notification-service
2 Summary:    Simple notification service
3 Version:    0.0.1
4 Release:    1
5 Group:      Application Framework/Notifications
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.bz2
8 BuildRequires: pkgconfig(eina) 
9 BuildRequires: pkgconfig(ecore) 
10 BuildRequires: pkgconfig(com-core) 
11 BuildRequires: pkgconfig(notification)
12
13 %description
14 Headless notification service that collects incoming notifications from the
15 the platform, maintains a database of active notifications, and broadcast updates
16 to all listeners.
17
18 %package test
19 Summary: Test clients for %{name}
20 Group:   Application Framework/Notifications
21 %description test
22 This package provides unit test used in the development of the notification service.
23
24 %prep
25 %setup -q -n %{name}-%{version}
26
27 %define PREFIX %{_prefix}/apps/
28
29 %build
30 %autogen
31 make %{?_smp_mflags}
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36
37 %files
38 %defattr(-,root,root,-)
39 %{_bindir}/notification-service
40 %{_libdir}/systemd/system/notifications.service
41 %{_libdir}/systemd/system/notifications.socket
42 %{_libdir}/systemd/system/sockets.target.wants/notifications.socket
43
44 %files test
45 %defattr(-,root,root,-)
46 %{_bindir}/sample-display-client
47 %{_bindir}/send-notification