Activate Wayland notifications in bluetooth_notification_client
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 %bcond_with wayland
2
3 Name:       notification-service
4 Summary:    Simple notification service
5 Version:    0.0.3
6 Release:    1
7 Group:      Application Framework/Notifications
8 License:    Flora
9 Source0:    %{name}-%{version}.tar.bz2
10 BuildRequires: pkgconfig(eina)
11 BuildRequires: pkgconfig(ecore)
12 BuildRequires: pkgconfig(com-core)
13 BuildRequires: pkgconfig(notification)
14 BuildRequires: pkgconfig(notification-service)
15 BuildRequires: pkgconfig(dbus-1)
16 BuildRequires: pkgconfig(dbus-glib-1)
17 BuildRequires: pkgconfig(bluetooth-api)
18 BuildRequires: pkgconfig(bundle)
19 %if %{with wayland}
20 BuildRequires: pkgconfig(libwlmessage)
21 %endif
22 %{?systemd_requires}
23
24 %description
25 Headless notification service that collects incoming notifications from the
26 the platform, maintains a database of active notifications, and broadcast updates
27 to all listeners.
28
29 %package test
30 Summary: Test clients for %{name}
31 Group:   Application Framework/Notifications
32 %description test
33 This package provides unit test used in the development of the notification service.
34
35 %prep
36 %setup -q -n %{name}-%{version}
37
38 %build
39 %if %{with wayland}
40 %autogen --enable-wayland
41 %else
42 %autogen
43 %endif
44 make %{?_smp_mflags}
45
46 %install
47 %make_install
48 %install_service graphical.target.wants notifications.service
49
50 %post
51 %systemd_post notifications.service
52
53 %preun
54 %systemd_preun notifications.service
55
56 %postun
57 %systemd_postun notifications.service
58
59 %files
60 %defattr(-,root,root,-)
61 %{_bindir}/notification-service
62 %{_unitdir}/notifications.service
63 %{_unitdir}/graphical.target.wants/notifications.service
64
65 %files test
66 %defattr(-,root,root,-)
67 %{_bindir}/sample-display-client
68 %{_bindir}/send-notification
69 %{_bindir}/bluetooth_notification_client