33aad4ff12c1157ff860e87b29057b921a8c04da
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 Name:       notification-service
2 Summary:    Simple notification service
3 Version:    0.0.3
4 Release:    1
5 Group:      Application Framework/Notifications
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.bz2
8 BuildRequires: pkgconfig(eina)
9 BuildRequires: pkgconfig(ecore)
10 BuildRequires: pkgconfig(com-core)
11 BuildRequires: pkgconfig(notification)
12 BuildRequires: pkgconfig(notification-service)
13 BuildRequires: pkgconfig(dbus-1)
14 BuildRequires: pkgconfig(dbus-glib-1)
15 BuildRequires: pkgconfig(bluetooth-api)
16 BuildRequires: pkgconfig(bundle)
17 %{?systemd_requires}
18
19 %description
20 Headless notification service that collects incoming notifications from the
21 the platform, maintains a database of active notifications, and broadcast updates
22 to all listeners.
23
24 %package test
25 Summary: Test clients for %{name}
26 Group:   Application Framework/Notifications
27 %description test
28 This package provides unit test used in the development of the notification service.
29
30 %prep
31 %setup -q -n %{name}-%{version}
32
33 %build
34 %autogen
35 make %{?_smp_mflags}
36
37 %install
38 %make_install
39 %install_service graphical.target.wants notifications.service
40
41 %post
42 %systemd_post notifications.service
43
44 %preun
45 %systemd_preun notifications.service
46
47 %postun
48 %systemd_postun notifications.service
49
50 %files
51 %defattr(-,root,root,-)
52 %{_bindir}/notification-service
53 %{_unitdir}/notifications.service
54 %{_unitdir}/graphical.target.wants/notifications.service
55
56 %files test
57 %defattr(-,root,root,-)
58 %{_bindir}/sample-display-client
59 %{_bindir}/send-notification
60 %{_bindir}/bluetooth_notification_client