pkgconf: fix bad dependencies on app-core-common-devel
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 %endif
15 Source1001:     app-core.manifest
16 BuildRequires:  pkgconfig(dbus-1)
17 BuildRequires:  pkgconfig(sensor)
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(aul)
20 BuildRequires:  pkgconfig(rua)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(elementary)
23 BuildRequires:  pkgconfig(ecore)
24 BuildRequires:  pkgconfig(gobject-2.0)
25 BuildRequires:  pkgconfig(glib-2.0)
26 BuildRequires:  pkgconfig(libtzplatform-config)
27 BuildRequires:  cmake
28
29 %description
30 SLP common application basic
31
32
33 %package efl
34 Summary:    App basic EFL
35 Group:      Development/Libraries
36 Requires(post): /sbin/ldconfig
37 Requires(postun): /sbin/ldconfig
38
39 %description efl
40 Application basic EFL
41
42
43 %package efl-devel
44 Summary:    App basic EFL (devel)
45 Group:      Development/Libraries
46 Requires:   %{name}-efl = %{version}-%{release}
47 Requires:   %{name}-common-devel = %{version}-%{release}
48
49 %description efl-devel
50 Application basic EFL (devel)
51
52
53 %package common
54 Summary:    App basics common
55 Group:      Development/Libraries
56 Requires(post): /sbin/ldconfig
57 Requires(postun): /sbin/ldconfig
58
59 %description common
60 Application basics common
61
62
63 %package common-devel
64 Summary:    App basics common (devel)
65 Group:      Development/Libraries
66 Requires:   %{name}-common = %{version}-%{release}
67 %if %{with x}
68 Requires:   pkgconfig(x11)
69 %endif
70
71 %description common-devel
72 Application basics common (devel)
73
74
75 %package template
76 Summary:    App basics template
77 Group:      Development/Libraries
78
79 %description template
80 Application basics template
81
82
83 %prep
84 %setup -q
85 cp %{SOURCE1001} .
86
87
88 %build
89
90 %cmake . \
91 %if %{with wayland}
92 -Dwith_wayland=TRUE\
93 %endif
94 %if %{with x}
95 -Dwith_x11=TRUE\
96 %endif
97 -DENABLE_GTK=OFF
98
99 make %{?_smp_mflags}
100
101
102 %install
103 rm -rf %{buildroot}
104 %make_install
105
106
107 %post -n app-core-efl -p /sbin/ldconfig
108
109 %postun -n app-core-efl -p /sbin/ldconfig
110
111 %post -n app-core-common -p /sbin/ldconfig
112
113 %postun -n app-core-common -p /sbin/ldconfig
114
115
116 %files efl
117 %manifest %{name}.manifest
118 %defattr(-,root,root,-)
119 %{_libdir}/libappcore-efl.so.*
120 %license LICENSE
121
122 %files efl-devel
123 %manifest %{name}.manifest
124 %defattr(-,root,root,-)
125 %{_includedir}/appcore/appcore-efl.h
126 %{_libdir}/libappcore-efl.so
127 %{_libdir}/pkgconfig/appcore-efl.pc
128
129 %files common
130 %manifest %{name}.manifest
131 %defattr(-,root,root,-)
132 %{_libdir}/libappcore-common.so.*
133 %license LICENSE
134
135 %files common-devel
136 %manifest %{name}.manifest
137 %defattr(-,root,root,-)
138 %{_libdir}/libappcore-common.so
139 %{_libdir}/pkgconfig/appcore-common.pc
140 %{_includedir}/appcore/appcore-common.h
141 %{_includedir}/SLP_Appcore_PG.h