Add license file
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 Name:       app-core
2 Summary:    Application basic
3 Version:    1.2
4 Release:    48
5 Group:      Application Framework
6 License:    Apache License, Version 2.0
7 Source0:    app-core-%{version}.tar.gz
8 Source101:  packaging/core-efl.target
9 BuildRequires:  pkgconfig(sensor)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(aul)
12 BuildRequires:  pkgconfig(rua)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(x11)
15 BuildRequires:  pkgconfig(elementary)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(ecore-x)
18 BuildRequires:  pkgconfig(gobject-2.0)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  cmake
21
22
23 %description
24 SLP common application basic
25
26
27
28 %package efl
29 Summary:    App basic EFL
30 Group:      Development/Libraries
31 Requires(post): /sbin/ldconfig
32 Requires(postun): /sbin/ldconfig
33
34 %description efl
35 Application basic EFL
36
37 %package efl-devel
38 Summary:    App basic EFL (devel)
39 Group:      Development/Libraries
40 Requires:   %{name}-efl = %{version}-%{release}
41 Requires:   %{name}-common-devel = %{version}-%{release}
42
43 %description efl-devel
44 Application basic EFL (devel)
45
46 %package common
47 Summary:    App basics common
48 Group:      Development/Libraries
49 Requires(post): /sbin/ldconfig
50 Requires(postun): /sbin/ldconfig
51
52 %description common
53 Application basics common
54
55 %package common-devel
56 Summary:    App basics common (devel)
57 Group:      Development/Libraries
58 Requires:   %{name}-common = %{version}-%{release}
59 Requires:   pkgconfig(sensor)
60 Requires:   pkgconfig(vconf)
61 Requires:   pkgconfig(elementary)
62 Requires:   pkgconfig(aul)
63
64 %description common-devel
65 Application basics common (devel)
66
67 %package template
68 Summary:    App basics template
69 Group:      Development/Libraries
70
71 %description template
72 Application basics template
73
74
75 %prep
76 %setup -q 
77
78 %build
79 %cmake . -DENABLE_GTK=OFF
80
81
82 make %{?jobs:-j%jobs}
83
84 %install
85 rm -rf %{buildroot}
86 %make_install
87 install -d %{buildroot}%{_prefix}/lib/systemd/user/core-efl.target.wants
88 install -m0644 %{SOURCE101} %{buildroot}%{_prefix}/lib/systemd/user/
89
90 mkdir -p %{buildroot}/usr/share/license
91 cp LICENSE %{buildroot}/usr/share/license/%{name}
92
93
94 %post efl -p /sbin/ldconfig
95
96 %postun efl -p /sbin/ldconfig
97
98 %post common -p /sbin/ldconfig
99
100 %postun common -p /sbin/ldconfig
101
102
103
104
105
106 %files efl
107 %manifest app-core.manifest
108 %defattr(-,root,root,-)
109 %{_libdir}/libappcore-efl.so.*
110
111 %files efl-devel
112 %defattr(-,root,root,-)
113 %{_includedir}/appcore/appcore-efl.h
114 %{_libdir}/libappcore-efl.so
115 %{_libdir}/pkgconfig/appcore-efl.pc
116
117 %files common
118 %manifest app-core.manifest
119 %defattr(-,root,root,-)
120 %{_libdir}/libappcore-common.so.*
121 %{_prefix}/lib/systemd/user/core-efl.target
122 %{_prefix}/lib/systemd/user/core-efl.target.wants/
123 /usr/share/license/%{name}
124
125 %files common-devel
126 %defattr(-,root,root,-)
127 %{_libdir}/libappcore-common.so
128 %{_libdir}/pkgconfig/appcore-common.pc
129 %{_includedir}/appcore/appcore-common.h
130 %{_includedir}/SLP_Appcore_PG.h
131