Remove unused files
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 %endif
15 Source1001:     app-core.manifest
16 BuildRequires:  pkgconfig(dbus-1)
17 BuildRequires:  pkgconfig(sensor)
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(aul)
20 BuildRequires:  pkgconfig(rua)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(elementary)
23 BuildRequires:  pkgconfig(ecore)
24 BuildRequires:  pkgconfig(gobject-2.0)
25 BuildRequires:  pkgconfig(glib-2.0)
26 BuildRequires:  pkgconfig(libtzplatform-config)
27 BuildRequires:  cmake
28
29 %description
30 SLP common application basic
31
32
33 %package efl
34 Summary:    App basic EFL
35 Group:      Development/Libraries
36 Requires(post): /sbin/ldconfig
37 Requires(postun): /sbin/ldconfig
38
39 %description efl
40 Application basic EFL
41
42
43 %package efl-devel
44 Summary:    App basic EFL (devel)
45 Group:      Development/Libraries
46 Requires:   %{name}-efl = %{version}-%{release}
47 Requires:   %{name}-common-devel = %{version}-%{release}
48
49 %description efl-devel
50 Application basic EFL (devel)
51
52
53 %package common
54 Summary:    App basics common
55 Group:      Development/Libraries
56 Requires(post): /sbin/ldconfig
57 Requires(postun): /sbin/ldconfig
58
59 %description common
60 Application basics common
61
62
63 %package common-devel
64 Summary:    App basics common (devel)
65 Group:      Development/Libraries
66 Requires:   %{name}-common = %{version}-%{release}
67 Requires:   pkgconfig(sensor)
68 Requires:   pkgconfig(vconf)
69 Requires:   pkgconfig(elementary)
70 Requires:   pkgconfig(aul)
71 %if %{with x}
72 Requires:   pkgconfig(x11)
73 %endif
74
75 %description common-devel
76 Application basics common (devel)
77
78
79 %package template
80 Summary:    App basics template
81 Group:      Development/Libraries
82
83 %description template
84 Application basics template
85
86
87 %prep
88 %setup -q 
89 cp %{SOURCE1001} .
90
91
92 %build
93
94 %cmake . \
95 %if %{with wayland}
96 -Dwith_wayland=TRUE\
97 %endif
98 %if %{with x}
99 -Dwith_x11=TRUE\
100 %endif
101 -DENABLE_GTK=OFF
102
103 make %{?_smp_mflags}
104
105
106 %install
107 rm -rf %{buildroot}
108 %make_install
109
110
111 %post -n app-core-efl -p /sbin/ldconfig
112
113 %postun -n app-core-efl -p /sbin/ldconfig
114
115 %post -n app-core-common -p /sbin/ldconfig
116
117 %postun -n app-core-common -p /sbin/ldconfig
118
119
120 %files efl
121 %manifest %{name}.manifest
122 %defattr(-,root,root,-)
123 %{_libdir}/libappcore-efl.so.*
124 %license LICENSE
125
126 %files efl-devel
127 %manifest %{name}.manifest
128 %defattr(-,root,root,-)
129 %{_includedir}/appcore/appcore-efl.h
130 %{_libdir}/libappcore-efl.so
131 %{_libdir}/pkgconfig/appcore-efl.pc
132
133 %files common
134 %manifest %{name}.manifest
135 %defattr(-,root,root,-)
136 %{_libdir}/libappcore-common.so.*
137 %license LICENSE
138
139 %files common-devel
140 %manifest %{name}.manifest
141 %defattr(-,root,root,-)
142 %{_libdir}/libappcore-common.so
143 %{_libdir}/pkgconfig/appcore-common.pc
144 %{_includedir}/appcore/appcore-common.h
145 %{_includedir}/SLP_Appcore_PG.h