implementation of app group
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 BuildRequires:  pkgconfig(eina)
15 %else if %{with wayland}
16 BuildRequires:  pkgconfig(ecore-wayland)
17 %endif
18 Source1001:     app-core.manifest
19 BuildRequires:  pkgconfig(dbus-1)
20 BuildRequires:  pkgconfig(sensor)
21 BuildRequires:  pkgconfig(vconf)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(rua)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(elementary)
26 BuildRequires:  pkgconfig(ecore)
27 BuildRequires:  pkgconfig(gobject-2.0)
28 BuildRequires:  pkgconfig(glib-2.0)
29 BuildRequires:  pkgconfig(libtzplatform-config)
30 BuildRequires:  pkgconfig(pkgmgr-info)
31 BuildRequires:  cmake
32
33 %description
34 SLP common application basic
35
36
37 %package efl
38 Summary:    App basic EFL
39 Group:      Development/Libraries
40 Requires(post): /sbin/ldconfig
41 Requires(postun): /sbin/ldconfig
42
43 %description efl
44 Application basic EFL
45
46
47 %package efl-devel
48 Summary:    App basic EFL (devel)
49 Group:      Development/Libraries
50 Requires:   %{name}-efl = %{version}-%{release}
51 Requires:   %{name}-common-devel = %{version}-%{release}
52
53 %description efl-devel
54 Application basic EFL (devel)
55
56
57 %package common
58 Summary:    App basics common
59 Group:      Development/Libraries
60 Requires(post): /sbin/ldconfig
61 Requires(postun): /sbin/ldconfig
62
63 %description common
64 Application basics common
65
66
67 %package common-devel
68 Summary:    App basics common (devel)
69 Group:      Development/Libraries
70 Requires:   %{name}-common = %{version}-%{release}
71 Requires:   pkgconfig(sensor)
72 Requires:   pkgconfig(vconf)
73 Requires:   pkgconfig(elementary)
74 Requires:   pkgconfig(aul)
75 %if %{with x}
76 Requires:   pkgconfig(x11)
77 %endif
78
79 %description common-devel
80 Application basics common (devel)
81
82
83 %package template
84 Summary:    App basics template
85 Group:      Development/Libraries
86
87 %description template
88 Application basics template
89
90
91 %prep
92 %setup -q 
93 cp %{SOURCE1001} .
94
95
96 %build
97
98 %cmake . \
99 %if %{with wayland}
100 -Dwith_wayland=TRUE\
101 %endif
102 %if %{with x}
103 -Dwith_x11=TRUE\
104 %endif
105 -DENABLE_GTK=OFF
106
107 make %{?_smp_mflags}
108
109
110 %install
111 rm -rf %{buildroot}
112 %make_install
113
114
115 %post -n app-core-efl -p /sbin/ldconfig
116
117 %postun -n app-core-efl -p /sbin/ldconfig
118
119 %post -n app-core-common -p /sbin/ldconfig
120
121 %postun -n app-core-common -p /sbin/ldconfig
122
123
124 %files efl
125 %manifest %{name}.manifest
126 %defattr(-,root,root,-)
127 %{_libdir}/libappcore-efl.so.*
128 %license LICENSE
129
130 %files efl-devel
131 %manifest %{name}.manifest
132 %defattr(-,root,root,-)
133 %{_includedir}/appcore/appcore-efl.h
134 %{_libdir}/libappcore-efl.so
135 %{_libdir}/pkgconfig/appcore-efl.pc
136
137 %files common
138 %manifest %{name}.manifest
139 %defattr(-,root,root,-)
140 %{_libdir}/libappcore-common.so.*
141 %license LICENSE
142
143 %files common-devel
144 %manifest %{name}.manifest
145 %defattr(-,root,root,-)
146 %{_libdir}/libappcore-common.so
147 %{_libdir}/pkgconfig/appcore-common.pc
148 %{_includedir}/appcore/appcore-common.h
149 %{_includedir}/SLP_Appcore_PG.h