change sys-noti to resourced dbus interface.
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with wayland}
12 Source101:      packaging/core-efl-wayland.target
13 %else
14 Source101:      packaging/core-efl-x.target
15 %endif
16 %if %{with x}
17 BuildRequires:  pkgconfig(x11)
18 BuildRequires:  pkgconfig(ecore-x)
19 %endif
20 Source1001:     app-core.manifest
21 BuildRequires:  pkgconfig(dbus-1)
22 BuildRequires:  pkgconfig(sensor)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(aul)
25 BuildRequires:  pkgconfig(rua)
26 BuildRequires:  pkgconfig(dlog)
27 BuildRequires:  pkgconfig(elementary)
28 BuildRequires:  pkgconfig(ecore)
29 BuildRequires:  pkgconfig(gobject-2.0)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(libtzplatform-config)
32 BuildRequires:  cmake
33
34 %description
35 SLP common application basic
36
37
38 %package efl
39 Summary:    App basic EFL
40 Group:      Development/Libraries
41 Requires(post): /sbin/ldconfig
42 Requires(postun): /sbin/ldconfig
43
44 %description efl
45 Application basic EFL
46
47
48 %package efl-devel
49 Summary:    App basic EFL (devel)
50 Group:      Development/Libraries
51 Requires:   %{name}-efl = %{version}-%{release}
52 Requires:   %{name}-common-devel = %{version}-%{release}
53
54 %description efl-devel
55 Application basic EFL (devel)
56
57
58 %package common
59 Summary:    App basics common
60 Group:      Development/Libraries
61 Requires(post): /sbin/ldconfig
62 Requires(postun): /sbin/ldconfig
63
64 %description common
65 Application basics common
66
67
68 %package common-devel
69 Summary:    App basics common (devel)
70 Group:      Development/Libraries
71 Requires:   %{name}-common = %{version}-%{release}
72 Requires:   pkgconfig(sensor)
73 Requires:   pkgconfig(vconf)
74 Requires:   pkgconfig(elementary)
75 Requires:   pkgconfig(aul)
76 %if %{with x}
77 Requires:   pkgconfig(x11)
78 %endif
79
80 %description common-devel
81 Application basics common (devel)
82
83
84 %package template
85 Summary:    App basics template
86 Group:      Development/Libraries
87
88 %description template
89 Application basics template
90
91
92 %prep
93 %setup -q 
94 cp %{SOURCE1001} .
95
96
97 %build
98
99 %cmake . \
100 %if %{with wayland}
101 -Dwith_wayland=TRUE\
102 %endif
103 %if %{with x}
104 -Dwith_x11=TRUE\
105 %endif
106 -DENABLE_GTK=OFF
107
108 make %{?_smp_mflags}
109
110
111 %install
112 rm -rf %{buildroot}
113 %make_install
114 install -d %{buildroot}%{_unitdir_user}/core-efl.target.wants
115 install -m0644 %{SOURCE101} %{buildroot}%{_unitdir_user}/core-efl.target
116
117
118 %post -n app-core-efl -p /sbin/ldconfig
119
120 %postun -n app-core-efl -p /sbin/ldconfig
121
122 %post -n app-core-common -p /sbin/ldconfig
123
124 %postun -n app-core-common -p /sbin/ldconfig
125
126
127 %files efl
128 %manifest %{name}.manifest
129 %defattr(-,root,root,-)
130 %{_libdir}/libappcore-efl.so.*
131 %license LICENSE
132
133 %files efl-devel
134 %manifest %{name}.manifest
135 %defattr(-,root,root,-)
136 %{_includedir}/appcore/appcore-efl.h
137 %{_libdir}/libappcore-efl.so
138 %{_libdir}/pkgconfig/appcore-efl.pc
139
140 %files common
141 %manifest %{name}.manifest
142 %defattr(-,root,root,-)
143 %{_libdir}/libappcore-common.so.*
144 %{_unitdir_user}/core-efl.target
145 %{_unitdir_user}/core-efl.target.wants/
146 %license LICENSE
147
148 %files common-devel
149 %manifest %{name}.manifest
150 %defattr(-,root,root,-)
151 %{_libdir}/libappcore-common.so
152 %{_libdir}/pkgconfig/appcore-common.pc
153 %{_includedir}/appcore/appcore-common.h
154 %{_includedir}/SLP_Appcore_PG.h