Use gdbus instead of dbus-glib
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 BuildRequires:  pkgconfig(eina)
15 %else
16 %if %{with wayland}
17 BuildRequires:  pkgconfig(ecore-wayland)
18 %endif
19 %endif
20 Source1001:     app-core.manifest
21 BuildRequires:  pkgconfig(gio-2.0)
22 BuildRequires:  pkgconfig(sensor)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(aul)
25 BuildRequires:  pkgconfig(rua)
26 BuildRequires:  pkgconfig(dlog)
27 BuildRequires:  pkgconfig(elementary)
28 BuildRequires:  pkgconfig(ecore)
29 BuildRequires:  pkgconfig(gobject-2.0)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(libtzplatform-config)
32 BuildRequires:  pkgconfig(pkgmgr-info)
33 BuildRequires:  cmake
34
35 %description
36 SLP common application basic
37
38
39 %package efl
40 Summary:    App basic EFL
41 Group:      Development/Libraries
42 Requires(post): /sbin/ldconfig
43 Requires(postun): /sbin/ldconfig
44
45 %description efl
46 Application basic EFL
47
48
49 %package efl-devel
50 Summary:    App basic EFL (devel)
51 Group:      Development/Libraries
52 Requires:   %{name}-efl = %{version}-%{release}
53 Requires:   %{name}-common-devel = %{version}-%{release}
54
55 %description efl-devel
56 Application basic EFL (devel)
57
58
59 %package common
60 Summary:    App basics common
61 Group:      Development/Libraries
62 Requires(post): /sbin/ldconfig
63 Requires(postun): /sbin/ldconfig
64
65 %description common
66 Application basics common
67
68
69 %package common-devel
70 Summary:    App basics common (devel)
71 Group:      Development/Libraries
72 Requires:   %{name}-common = %{version}-%{release}
73 Requires:   pkgconfig(sensor)
74 Requires:   pkgconfig(vconf)
75 Requires:   pkgconfig(elementary)
76 Requires:   pkgconfig(aul)
77 %if %{with x}
78 Requires:   pkgconfig(x11)
79 %endif
80
81 %description common-devel
82 Application basics common (devel)
83
84
85 %package template
86 Summary:    App basics template
87 Group:      Development/Libraries
88
89 %description template
90 Application basics template
91
92 %if "%{?tizen_profile_name}" == "wearable"
93 %define appfw_feature_background_management 1
94 %else
95 %if "%{?tizen_profile_name}" == "mobile"
96 %define appfw_feature_background_management 1
97 %else
98 %if "%{?tizen_profile_name}" == "tv"
99 %define appfw_feature_background_management 0
100 %endif
101 %endif
102 %endif
103
104 %prep
105 %setup -q
106 cp %{SOURCE1001} .
107
108 %build
109 %if %{with wayland}
110 _WITH_WAYLAND=ON
111 %endif
112 %if %{with x}
113 _WITH_X11=ON
114 %endif
115 %if 0%{?appfw_feature_background_management}
116 _APPFW_FEATURE_BACKGROUND_MANAGEMENT=ON
117 %endif
118
119 %cmake . \
120         -D_WITH_WAYLAND:BOOL=${_WITH_WAYLAND} \
121         -D_WITH_X11:BOOL=${_WITH_X11} \
122         -D_APPFW_FEATURE_BACKGROUND_MANAGEMENT:BOOL=${_APPFW_FEATURE_BACKGROUND_MANAGEMENT} \
123         -DENABLE_GTK=OFF
124
125 make %{?_smp_mflags}
126
127
128 %install
129 rm -rf %{buildroot}
130 %make_install
131
132
133 %post -n app-core-efl -p /sbin/ldconfig
134
135 %postun -n app-core-efl -p /sbin/ldconfig
136
137 %post -n app-core-common -p /sbin/ldconfig
138
139 %postun -n app-core-common -p /sbin/ldconfig
140
141
142 %files efl
143 %manifest %{name}.manifest
144 %{_libdir}/libappcore-efl.so.*
145 %license LICENSE
146
147 %files efl-devel
148 %manifest %{name}.manifest
149 %{_includedir}/appcore/appcore-efl.h
150 %{_libdir}/libappcore-efl.so
151 %{_libdir}/pkgconfig/appcore-efl.pc
152
153 %files common
154 %manifest %{name}.manifest
155 %{_libdir}/libappcore-common.so.*
156 %license LICENSE
157
158 %files common-devel
159 %manifest %{name}.manifest
160 %{_libdir}/libappcore-common.so
161 %{_libdir}/pkgconfig/appcore-common.pc
162 %{_includedir}/appcore/appcore-common.h
163 %{_includedir}/SLP_Appcore_PG.h