Fix build break
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 BuildRequires:  pkgconfig(eina)
15 %else if %{with wayland}
16 BuildRequires:  pkgconfig(ecore-wayland)
17 %endif
18 Source1001:     app-core.manifest
19 BuildRequires:  pkgconfig(dbus-1)
20 BuildRequires:  pkgconfig(sensor)
21 BuildRequires:  pkgconfig(vconf)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(rua)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(elementary)
26 BuildRequires:  pkgconfig(ecore)
27 BuildRequires:  pkgconfig(gobject-2.0)
28 BuildRequires:  pkgconfig(glib-2.0)
29 BuildRequires:  pkgconfig(libtzplatform-config)
30 BuildRequires:  cmake
31
32 %description
33 SLP common application basic
34
35
36 %package efl
37 Summary:    App basic EFL
38 Group:      Development/Libraries
39 Requires(post): /sbin/ldconfig
40 Requires(postun): /sbin/ldconfig
41
42 %description efl
43 Application basic EFL
44
45
46 %package efl-devel
47 Summary:    App basic EFL (devel)
48 Group:      Development/Libraries
49 Requires:   %{name}-efl = %{version}-%{release}
50 Requires:   %{name}-common-devel = %{version}-%{release}
51
52 %description efl-devel
53 Application basic EFL (devel)
54
55
56 %package common
57 Summary:    App basics common
58 Group:      Development/Libraries
59 Requires(post): /sbin/ldconfig
60 Requires(postun): /sbin/ldconfig
61
62 %description common
63 Application basics common
64
65
66 %package common-devel
67 Summary:    App basics common (devel)
68 Group:      Development/Libraries
69 Requires:   %{name}-common = %{version}-%{release}
70 Requires:   pkgconfig(sensor)
71 Requires:   pkgconfig(vconf)
72 Requires:   pkgconfig(elementary)
73 Requires:   pkgconfig(aul)
74 %if %{with x}
75 Requires:   pkgconfig(x11)
76 %endif
77
78 %description common-devel
79 Application basics common (devel)
80
81
82 %package template
83 Summary:    App basics template
84 Group:      Development/Libraries
85
86 %description template
87 Application basics template
88
89
90 %prep
91 %setup -q 
92 cp %{SOURCE1001} .
93
94
95 %build
96
97 %cmake . \
98 %if %{with wayland}
99 -Dwith_wayland=TRUE\
100 %endif
101 %if %{with x}
102 -Dwith_x11=TRUE\
103 %endif
104 -DENABLE_GTK=OFF
105
106 make %{?_smp_mflags}
107
108
109 %install
110 rm -rf %{buildroot}
111 %make_install
112
113
114 %post -n app-core-efl -p /sbin/ldconfig
115
116 %postun -n app-core-efl -p /sbin/ldconfig
117
118 %post -n app-core-common -p /sbin/ldconfig
119
120 %postun -n app-core-common -p /sbin/ldconfig
121
122
123 %files efl
124 %manifest %{name}.manifest
125 %defattr(-,root,root,-)
126 %{_libdir}/libappcore-efl.so.*
127 %license LICENSE
128
129 %files efl-devel
130 %manifest %{name}.manifest
131 %defattr(-,root,root,-)
132 %{_includedir}/appcore/appcore-efl.h
133 %{_libdir}/libappcore-efl.so
134 %{_libdir}/pkgconfig/appcore-efl.pc
135
136 %files common
137 %manifest %{name}.manifest
138 %defattr(-,root,root,-)
139 %{_libdir}/libappcore-common.so.*
140 %license LICENSE
141
142 %files common-devel
143 %manifest %{name}.manifest
144 %defattr(-,root,root,-)
145 %{_libdir}/libappcore-common.so
146 %{_libdir}/pkgconfig/appcore-common.pc
147 %{_includedir}/appcore/appcore-common.h
148 %{_includedir}/SLP_Appcore_PG.h