ff0dfe84732824ce7c7e0358bdee04eb9d3c7048
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           app-core
5 Summary:        Application basic
6 Version:        1.2
7 Release:        0
8 Group:          Application Framework/Libraries
9 License:        Apache-2.0
10 Source0:        app-core-%{version}.tar.gz
11 %if %{with x}
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(ecore-x)
14 BuildRequires:  pkgconfig(eina)
15 %else
16 %if %{with wayland}
17 BuildRequires:  pkgconfig(ecore-wayland)
18 BuildRequires:  pkgconfig(wayland-client)
19 BuildRequires:  pkgconfig(tizen-extension-client)
20 BuildRequires:  pkgconfig(wayland-tbm-client)
21 %endif
22 %endif
23 Source1001:     app-core.manifest
24 BuildRequires:  pkgconfig(gio-2.0)
25 BuildRequires:  pkgconfig(sensor)
26 BuildRequires:  pkgconfig(vconf)
27 BuildRequires:  pkgconfig(aul)
28 BuildRequires:  pkgconfig(rua)
29 BuildRequires:  pkgconfig(dlog)
30 BuildRequires:  pkgconfig(elementary)
31 BuildRequires:  pkgconfig(ecore)
32 BuildRequires:  pkgconfig(gobject-2.0)
33 BuildRequires:  pkgconfig(glib-2.0)
34 BuildRequires:  pkgconfig(pkgmgr-info)
35 BuildRequires:  pkgconfig(ttrace)
36 BuildRequires:  cmake
37 BuildRequires:  pkgconfig(capi-system-info)
38
39 %description
40 SLP common application basic
41
42
43 %package efl
44 Summary:    App basic EFL
45 Group:      Development/Libraries
46 Requires(post): /sbin/ldconfig
47 Requires(postun): /sbin/ldconfig
48
49 %description efl
50 Application basic EFL
51
52
53 %package efl-devel
54 Summary:    App basic EFL (devel)
55 Group:      Development/Libraries
56 Requires:   %{name}-efl = %{version}-%{release}
57 Requires:   %{name}-common-devel = %{version}-%{release}
58
59 %description efl-devel
60 Application basic EFL (devel)
61
62
63 %package common
64 Summary:    App basics common
65 Group:      Development/Libraries
66 Requires(post): /sbin/ldconfig
67 Requires(postun): /sbin/ldconfig
68
69 %description common
70 Application basics common
71
72
73 %package common-devel
74 Summary:    App basics common (devel)
75 Group:      Development/Libraries
76 Requires:   %{name}-common = %{version}-%{release}
77 Requires:   pkgconfig(sensor)
78 Requires:   pkgconfig(vconf)
79 Requires:   pkgconfig(elementary)
80 Requires:   pkgconfig(aul)
81 %if %{with x}
82 Requires:   pkgconfig(x11)
83 %endif
84
85 %description common-devel
86 Application basics common (devel)
87
88
89 %package template
90 Summary:    App basics template
91 Group:      Development/Libraries
92
93 %description template
94 Application basics template
95
96 %prep
97 %setup -q
98 cp %{SOURCE1001} .
99
100 %build
101 %if %{with wayland}
102 _WITH_WAYLAND=ON
103 %endif
104 %if %{with x}
105 _WITH_X11=ON
106 %endif
107
108 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
109 %cmake . \
110         -D_WITH_WAYLAND:BOOL=${_WITH_WAYLAND} \
111         -D_WITH_X11:BOOL=${_WITH_X11} \
112         -DENABLE_GTK=OFF \
113         -DFULLVER=%{version} \
114         -DMAJORVER=${MAJORVER}
115
116 make %{?_smp_mflags}
117
118
119 %install
120 rm -rf %{buildroot}
121 %make_install
122
123
124 %post -n app-core-efl -p /sbin/ldconfig
125
126 %postun -n app-core-efl -p /sbin/ldconfig
127
128 %post -n app-core-common -p /sbin/ldconfig
129
130 %postun -n app-core-common -p /sbin/ldconfig
131
132
133 %files efl
134 %manifest %{name}.manifest
135 %{_libdir}/libappcore-efl.so.*
136 %license LICENSE
137
138 %files efl-devel
139 %manifest %{name}.manifest
140 %{_includedir}/appcore/appcore-efl.h
141 %{_libdir}/libappcore-efl.so
142 %{_libdir}/pkgconfig/appcore-efl.pc
143
144 %files common
145 %manifest %{name}.manifest
146 %{_libdir}/libappcore-common.so.*
147 %license LICENSE
148
149 %files common-devel
150 %manifest %{name}.manifest
151 %{_libdir}/libappcore-common.so
152 %{_libdir}/pkgconfig/appcore-common.pc
153 %{_includedir}/appcore/appcore-common.h
154 %{_includedir}/SLP_Appcore_PG.h