Release version 1.5.0
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 Name:           app-core
2 Summary:        Application basic
3 Version:        1.5.0
4 Release:        0
5 Group:          Application Framework/Libraries
6 License:        Apache-2.0
7 Source0:        app-core-%{version}.tar.gz
8 BuildRequires:  pkgconfig(ecore-wayland)
9 BuildRequires:  pkgconfig(wayland-client)
10 BuildRequires:  pkgconfig(tizen-extension-client)
11 BuildRequires:  pkgconfig(wayland-tbm-client)
12 Source1001:     app-core.manifest
13 BuildRequires:  pkgconfig(gio-2.0)
14 BuildRequires:  pkgconfig(sensor)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(aul)
17 BuildRequires:  pkgconfig(rua)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(ecore)
21 BuildRequires:  pkgconfig(gobject-2.0)
22 BuildRequires:  pkgconfig(glib-2.0)
23 BuildRequires:  pkgconfig(pkgmgr-info)
24 BuildRequires:  pkgconfig(ttrace)
25 BuildRequires:  cmake
26 BuildRequires:  pkgconfig(capi-system-info)
27
28 %description
29 SLP common application basic
30
31
32 %package efl
33 Summary:    App basic EFL
34 Group:      Development/Libraries
35 Requires(post): /sbin/ldconfig
36 Requires(postun): /sbin/ldconfig
37
38 %description efl
39 Application basic EFL
40
41
42 %package efl-devel
43 Summary:    App basic EFL (devel)
44 Group:      Development/Libraries
45 Requires:   %{name}-efl = %{version}-%{release}
46 Requires:   %{name}-common-devel = %{version}-%{release}
47
48 %description efl-devel
49 Application basic EFL (devel)
50
51
52 %package common
53 Summary:    App basics common
54 Group:      Development/Libraries
55 Requires(post): /sbin/ldconfig
56 Requires(postun): /sbin/ldconfig
57
58 %description common
59 Application basics common
60
61
62 %package common-devel
63 Summary:    App basics common (devel)
64 Group:      Development/Libraries
65 Requires:   %{name}-common = %{version}-%{release}
66 Requires:   pkgconfig(sensor)
67 Requires:   pkgconfig(vconf)
68 Requires:   pkgconfig(elementary)
69 Requires:   pkgconfig(aul)
70
71 %description common-devel
72 Application basics common (devel)
73
74
75 %package template
76 Summary:    App basics template
77 Group:      Development/Libraries
78
79 %description template
80 Application basics template
81
82 %prep
83 %setup -q
84 cp %{SOURCE1001} .
85
86 %build
87 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
88 %cmake . \
89         -DENABLE_GTK=OFF \
90         -DFULLVER=%{version} \
91         -DMAJORVER=${MAJORVER}
92
93 make %{?_smp_mflags}
94
95
96 %install
97 rm -rf %{buildroot}
98 %make_install
99
100
101 %post -n app-core-efl -p /sbin/ldconfig
102
103 %postun -n app-core-efl -p /sbin/ldconfig
104
105 %post -n app-core-common -p /sbin/ldconfig
106
107 %postun -n app-core-common -p /sbin/ldconfig
108
109
110 %files efl
111 %manifest %{name}.manifest
112 %{_libdir}/libappcore-efl.so.*
113 %license LICENSE
114
115 %files efl-devel
116 %manifest %{name}.manifest
117 %{_includedir}/appcore/appcore-efl.h
118 %{_includedir}/appcore/appcore_ui_base.h
119 %{_libdir}/libappcore-efl.so
120 %{_libdir}/pkgconfig/appcore-efl.pc
121
122 %files common
123 %manifest %{name}.manifest
124 %{_libdir}/libappcore-common.so.*
125 %license LICENSE
126
127 %files common-devel
128 %manifest %{name}.manifest
129 %{_libdir}/libappcore-common.so
130 %{_libdir}/pkgconfig/appcore-common.pc
131 %{_includedir}/appcore/appcore-common.h
132 %{_includedir}/appcore/appcore_base.h
133