Remove unused vconf key
[platform/core/appfw/ail.git] / packaging / ail.spec
1 Name:           ail
2 Version:        0.2.80
3 Release:        0
4 License:        Apache-2.0
5 Summary:        Application Information Library
6 Group:          Application Framework/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     ail.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(db-util)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(libsmack)
13 BuildRequires:  pkgconfig(sqlite3)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(xdgmime)
16 BuildRequires:  pkgconfig(libtzplatform-config)
17 Provides:       libail = %{version}-%{release}
18
19 %description
20 Application Information Library package
21
22 %package devel
23 Summary:        Application Information Library Development files
24 Requires:       libail = %{version}-%{release}
25 Requires:       pkgconfig(libtzplatform-config)
26 Requires:       pkgconfig(libsmack)
27
28 %description devel
29 Application Information Library Development files package
30
31 %package vconf-devel
32 Summary:        Application Information Library Development files
33 Requires:       libail = %{version}-%{release}
34
35 %description vconf-devel
36 Application Information Library Development files package
37 This developement file purpose concerns the issue TC-2399
38 https://bugs.tizen.org/jira/browse/TC-2399
39
40
41 %prep
42 %setup -q
43 cp %{SOURCE1001} .
44
45 %build
46 CFLAGS="$CFLAGS -fpic"
47
48 %if 0%{?tizen_build_binary_release_type_eng}
49 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
50 export CXXFLAGS="$CXXFLAGS ?DTIZEN_ENGINEER_MODE"
51 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
52 %endif
53
54 %cmake .  -DTZ_SYS_RW_DESKTOP_APP=%TZ_SYS_RW_DESKTOP_APP \
55           -DBUILD_PKGTYPE=rpm
56
57 %__make %{?_smp_mflags}
58
59 %install
60 %make_install
61
62 %post
63 ldconfig
64 # Create tizenglobalapp user needed for global installation
65 useradd -d %TZ_SYS_RW_APP -m %TZ_SYS_GLOBALAPP_USER -r -c "system user for common applications" -g root
66
67 #mkdir -p %%TZ_SYS_RW_APP/.config/xwalk-service/applications
68 #cd %%TZ_SYS_RW_APP/
69 #ln -s .config/xwalk-service/applications/
70
71
72 mkdir -p %{TZ_SYS_RO_DESKTOP_APP}
73 mkdir -p %{TZ_SYS_RW_DESKTOP_APP}
74 mkdir -p %{TZ_SYS_RW_APP}
75 mkdir -p %{TZ_SYS_DB}
76 mkdir -p %{TZ_SYS_RW_ICONS}/default/small
77
78 chsmack -a '*' %{TZ_SYS_DB}
79 chsmack -a '*' %{TZ_SYS_RW_APP}
80 chsmack -a '*' %{TZ_SYS_RW_DESKTOP_APP}
81 chsmack -a '*' %{TZ_SYS_RO_DESKTOP_APP}
82 chsmack -a '*' %{TZ_SYS_RW_ICONS}
83 chsmack -a '*' %{TZ_SYS_RW_ICONS}/default
84 chsmack -a '*' %{TZ_SYS_RW_ICONS}/default/small/
85
86 chmod g+w %{TZ_SYS_RW_DESKTOP_APP}
87 chmod g+w %{TZ_SYS_RO_DESKTOP_APP}
88 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_RW_DESKTOP_APP}
89 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_RO_DESKTOP_APP}
90 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_RW_APP}
91 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_DB}
92 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_DB}
93 chown %TZ_SYS_GLOBALAPP_USER:root -R %{TZ_SYS_RW_ICONS}
94
95 ail_createdb 2>/dev/null
96 ail_syncdb 2>/dev/null
97 chsmack -a '*' %{TZ_SYS_DB}/.app_info.db*
98  
99 %postun
100 /sbin/ldconfig
101 if [ $1 == 0 ]; then
102     rm -f %{TZ_SYS_DB}/.app_info.db*
103 fi
104
105 %files
106 %manifest %{name}.manifest
107 %license LICENSE
108 %attr(06775,root,root) %{_bindir}/ail_createdb
109 %attr(0775,root,root) %{_bindir}/ail_createdb_user
110 %attr(06775,root,root) %{_bindir}/ail_syncdb
111 %attr(0775,root,root) %{_bindir}/ail_syncdb_user
112 #obsolete tools
113 %attr(06775,root,root) %{_bindir}/ail_initdb
114 %attr(0775,root,root) %{_bindir}/ail_initdb_user
115 %{_bindir}/ail_fota
116 %{_bindir}/ail_desktop
117 %{_bindir}/ail_filter
118 %{_bindir}/ail_list
119 %{_bindir}/ail_package
120 %{_datadir}/install-info/*
121 %{_libdir}/libail.so.0
122 %{_libdir}/libail.so.0.1.0
123
124 %files devel
125 %manifest %{name}.manifest
126 %{_includedir}/ail.h
127 %{_libdir}/libail.so
128 %{_libdir}/pkgconfig/ail.pc
129
130 %files vconf-devel
131 %{_includedir}/ail_vconf.h