Fix vconf values' smack label
[platform/core/appfw/ail.git] / packaging / ail.spec
1 Name:           ail
2 Version:        0.2.80
3 Release:        0
4 License:        Apache-2.0
5 Summary:        Application Information Library
6 Group:          Application Framework/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     ail.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(db-util)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(libsmack)
13 BuildRequires:  pkgconfig(sqlite3)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(xdgmime)
16 BuildRequires:  pkgconfig(libtzplatform-config)
17 Provides:       libail = %{version}-%{release}
18
19 %description
20 Application Information Library package
21
22 %package devel
23 Summary:        Application Information Library Development files
24 Requires:       libail = %{version}-%{release}
25 Requires:       pkgconfig(libtzplatform-config)
26 Requires:       pkgconfig(libsmack)
27
28 %description devel
29 Application Information Library Development files package
30
31 %package vconf-devel
32 Summary:        Application Information Library Development files
33 Requires:       libail = %{version}-%{release}
34
35 %description vconf-devel
36 Application Information Library Development files package
37 This developement file purpose concerns the issue TC-2399
38 https://bugs.tizen.org/jira/browse/TC-2399
39
40
41 %prep
42 %setup -q
43 cp %{SOURCE1001} .
44
45 %build
46 CFLAGS="$CFLAGS -fpic"
47
48 %if 0%{?tizen_build_binary_release_type_eng}
49 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
50 export CXXFLAGS="$CXXFLAGS ?DTIZEN_ENGINEER_MODE"
51 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
52 %endif
53
54 %cmake .  -DTZ_SYS_RW_DESKTOP_APP=%TZ_SYS_RW_DESKTOP_APP \
55           -DBUILD_PKGTYPE=rpm
56
57 %__make %{?_smp_mflags}
58
59 %install
60 %make_install
61
62 %post
63 ldconfig
64 # Create tizenglobalapp user needed for global installation
65 useradd -d %TZ_SYS_RW_APP -m %TZ_SYS_GLOBALAPP_USER -r -c "system user for common applications" -g root
66
67 #mkdir -p %%TZ_SYS_RW_APP/.config/xwalk-service/applications
68 #cd %%TZ_SYS_RW_APP/
69 #ln -s .config/xwalk-service/applications/
70
71 vconftool set -t string db/ail/ail_info "0" -f -s User::App::Shared
72 vconftool set -t string db/menuscreen/desktop "0" -f -s User::App::Shared
73 vconftool set -t string db/menu_widget/language "en_US.utf8" -f -s User::App::Shared
74
75 mkdir -p %{TZ_SYS_RO_DESKTOP_APP}
76 mkdir -p %{TZ_SYS_RW_DESKTOP_APP}
77 mkdir -p %{TZ_SYS_RW_APP}
78 mkdir -p %{TZ_SYS_DB}
79 mkdir -p %{TZ_SYS_RW_ICONS}/default/small
80
81 chsmack -a '*' %{TZ_SYS_DB}
82 chsmack -a '*' %{TZ_SYS_RW_APP}
83 chsmack -a '*' %{TZ_SYS_RW_DESKTOP_APP}
84 chsmack -a '*' %{TZ_SYS_RO_DESKTOP_APP}
85 chsmack -a '*' %{TZ_SYS_RW_ICONS}
86 chsmack -a '*' %{TZ_SYS_RW_ICONS}/default
87 chsmack -a '*' %{TZ_SYS_RW_ICONS}/default/small/
88
89 chmod g+w %{TZ_SYS_RW_DESKTOP_APP}
90 chmod g+w %{TZ_SYS_RO_DESKTOP_APP}
91 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_RW_DESKTOP_APP}
92 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_RO_DESKTOP_APP}
93 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_RW_APP}
94 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_DB}
95 chown %TZ_SYS_GLOBALAPP_USER:root %{TZ_SYS_DB}
96 chown %TZ_SYS_GLOBALAPP_USER:root -R %{TZ_SYS_RW_ICONS}
97
98 ail_createdb 2>/dev/null
99 ail_syncdb 2>/dev/null
100 chsmack -a '*' %{TZ_SYS_DB}/.app_info.db*
101  
102 %postun
103 /sbin/ldconfig
104 if [ $1 == 0 ]; then
105     rm -f %{TZ_SYS_DB}/.app_info.db*
106 fi
107
108 %files
109 %manifest %{name}.manifest
110 %license LICENSE
111 %attr(06775,root,root) %{_bindir}/ail_createdb
112 %attr(0775,root,root) %{_bindir}/ail_createdb_user
113 %attr(06775,root,root) %{_bindir}/ail_syncdb
114 %attr(0775,root,root) %{_bindir}/ail_syncdb_user
115 #obsolete tools
116 %attr(06775,root,root) %{_bindir}/ail_initdb
117 %attr(0775,root,root) %{_bindir}/ail_initdb_user
118 %{_bindir}/ail_fota
119 %{_bindir}/ail_desktop
120 %{_bindir}/ail_filter
121 %{_bindir}/ail_list
122 %{_bindir}/ail_package
123 %{_datadir}/install-info/*
124 %{_libdir}/libail.so.0
125 %{_libdir}/libail.so.0.1.0
126
127 %files devel
128 %manifest %{name}.manifest
129 %{_includedir}/ail.h
130 %{_libdir}/libail.so
131 %{_libdir}/pkgconfig/ail.pc
132
133 %files vconf-devel
134 %{_includedir}/ail_vconf.h