Improve typing of constants data
[platform/core/api/power.git] / packaging / capi-system-power.spec
1 Name:       capi-system-power
2 Summary:    A power library in SLP C API
3 Version:    0.1.1
4 Release:    0
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-system-power.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(pmapi)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(capi-base-common)
14 BuildRequires:  pkgconfig(vconf)
15
16 %description
17 A power library in SLP C API package.
18
19 %package devel
20 Summary:  A power library in SLP C API (Development)
21 Group:    Development/System
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25 A power library in SLP C API (Development) package.
26 %devel_desc
27
28 %prep
29 %setup -q
30
31 %build
32 cp %{SOURCE1001} .
33 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
34 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
35 %__make %{?jobs:-j%jobs}
36
37 %install
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %manifest %{name}.manifest
46 %license LICENSE.APLv2
47 %{_libdir}/libcapi-system-power.so.*
48
49 %files devel
50 %manifest %{name}.manifest
51 %{_includedir}/system/power.h
52 %{_libdir}/pkgconfig/*.pc
53 %{_libdir}/libcapi-system-power.so