Directory path migration
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
1 Name: capi-location-manager
2 Summary: A Location Manager library in Tizen Native API
3 Version: 0.7.0
4 Release: 1
5 Group: Location/API
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(lbs-location)
12 BuildRequires: pkgconfig(capi-base-common)
13 BuildRequires: pkgconfig(capi-system-info)
14 BuildRequires: pkgconfig(vconf)
15 Requires(post): /sbin/ldconfig
16 Requires(postun): /sbin/ldconfig
17
18 %description
19 A Location Manager library in Tizen Native API
20
21
22 %package devel
23 Summary:  A Location Manager library in Tizen Native API (Development)
24 Group:    Location/Development
25 Requires: %{name} = %{version}-%{release}
26
27 %description devel
28 A Location Manager library in Tizen Native API (Development)
29
30
31 %prep
32 %setup -q
33 cp %{SOURCE1001} .
34
35 %build
36
37 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
38 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
39 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
40
41 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
42 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
43 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50
51 #mkdir -p %{buildroot}/usr/share/license
52 #cp LICENSE %{buildroot}/usr/share/license/%{name}
53
54 %post -p /sbin/ldconfig
55
56 %postun -p /sbin/ldconfig
57
58 %files
59 %manifest %{name}.manifest
60 %license LICENSE
61 %{_libdir}/libcapi-location-manager.so.*
62
63 %files devel
64 %{_includedir}/location/*.h
65 %{_libdir}/pkgconfig/*.pc
66 %{_libdir}/libcapi-location-manager.so
67
68
69 %if 1
70 %package test
71 Summary:    Test application of Location Manager
72 Group:      Location/Testing
73 Requires: %{name} = %{version}-%{release}
74
75 %description test
76 Test application of Location Manager
77
78 %files test
79 %manifest test/capi-location-manager-test.manifest
80 #/usr/share/packages/capi-location-manager-test.xml
81 /opt/usr/devel/location/location_test
82 %endif