Remove unused code about test application
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
1 Name: capi-location-manager
2 Summary: A Location Manager library in Tizen Native API
3 Version: 0.7.10
4 Release: 1
5 Group: Location/API
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(lbs-location)
12 BuildRequires: pkgconfig(capi-base-common)
13 BuildRequires: pkgconfig(capi-system-info)
14 BuildRequires: pkgconfig(vconf)
15 BuildRequires: pkgconfig(libtzplatform-config)
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18
19 %description
20 A Location Manager library in Tizen Native API
21
22
23 %package devel
24 Summary:  A Location Manager library in Tizen Native API (Development)
25 Group:    Location/Development
26 Requires: %{name} = %{version}-%{release}
27
28 %description devel
29 A Location Manager library in Tizen Native API (Development)
30
31
32 %prep
33 %setup -q
34 cp %{SOURCE1001} .
35
36 %build
37
38 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
39 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
40 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} -DTZ_SYS_BIN=%{TZ_SYS_BIN} \
41
42 make %{?jobs:-j%jobs}
43
44 %install
45 rm -rf %{buildroot}
46 %make_install
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files
53 %manifest %{name}.manifest
54 %license LICENSE
55 %{_libdir}/libcapi-location-manager.so.*
56 %{_bindir}/location_test
57
58 %files devel
59 %{_includedir}/location/*.h
60 %{_libdir}/pkgconfig/*.pc
61 %{_libdir}/libcapi-location-manager.so