resetting manifest requested domain to floor
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
1 Name:       capi-location-manager
2 Summary:    A Location Manager library in Tizen Native API
3 Version: 0.1.11
4 Release:    1
5 Group:      Location/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-location-manager.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(location)
12 BuildRequires:  pkgconfig(capi-base-common)
13
14 %description
15 A Location Manager library in Tizen Native API.
16
17
18 %package devel
19 Summary:  A Location Manager library in Tizen Native API (Development)
20 Group:    Location/Development
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24 %devel_desc
25
26
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32
33 %build
34 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
35 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
36
37 make %{?jobs:-j%jobs}
38
39 %install
40 %make_install
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46
47 %files
48 %manifest %{name}.manifest
49 %license LICENSE
50 %manifest capi-location-manager.manifest
51 %{_libdir}/libcapi-location-manager.so.*
52
53 %files devel
54 %manifest %{name}.manifest
55 %{_includedir}/location/*.h
56 %{_libdir}/pkgconfig/*.pc
57 %{_libdir}/libcapi-location-manager.so
58
59