22b657f93b9196072dc94d676fd6b9004bff30ce
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
1 #sbs-git:slp/api/location-manager capi-location-manager 0.1.0 d1ee09a32e8bc0e9ed48ece37c641a7393c086c5
2 Name:       capi-location-manager
3 Summary:    A Location Manager library in Tizen Native API
4 Version: 0.1.9
5 Release:    1
6 Group:      System/Libraries
7 License:    Apache License, Version 2.0
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(location)
12 BuildRequires:  pkgconfig(capi-base-common)
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16 %description
17
18
19 %package devel
20 Summary:  A Location Manager library in Tizen Native API (Development)
21 Group:    TO_BE/FILLED_IN
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25
26
27
28 %prep
29 %setup -q
30
31
32 %build
33 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
34 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46
47 %files
48 %manifest capi-location-manager.manifest
49 %{_libdir}/libcapi-location-manager.so.*
50
51 %files devel
52 %{_includedir}/location/*.h
53 %{_libdir}/pkgconfig/*.pc
54 %{_libdir}/libcapi-location-manager.so
55
56