not build without x
[platform/adaptation/xf86-input-gesture.git] / packaging / xf86-input-gesture.spec
1 %bcond_with x
2
3 #sbs-git:slp/pkgs/xorg/driver/xserver-xorg-input-gesture xorg-x11-drv-gesture 0.1.0 fb1092a8ea453d658b38d5c28e67a58462d7c931
4 Name:   xf86-input-gesture
5 Summary:    X.Org X server -- Xserver gesture driver
6 Version: 0.1.2
7 Release:    7
8 Group:      System/X Hardware Support
9 License:    MIT
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  pkgconfig(xorg-server)
12 BuildRequires:  xorg-x11-proto-gesture
13 BuildRequires:  pkgconfig(xproto)
14 BuildRequires:  pkgconfig(inputproto)
15 BuildRequires:  pkgconfig(resourceproto)
16 BuildRequires:  pkgconfig(xorg-macros)
17
18 %if !%{with x}
19 ExclusiveArch:
20 %endif
21
22 %description
23  This package provides the driver for recognizing gesture(s) using button
24 and motion events inside X server.
25
26
27 %package devel
28 Summary:    Development files for xorg gesture driver
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 xorg-x11-drv-gesture development files
34
35
36 %prep
37 %setup -q
38
39 %build
40
41 %autogen -ivf
42 %configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
43
44 make %{?jobs:-j%jobs}
45
46 %install
47 rm -rf %{buildroot}
48 mkdir -p %{buildroot}/usr/share/license
49 cp -af COPYING %{buildroot}/usr/share/license/%{name}
50 %make_install
51
52 %remove_docs
53
54 %files
55 %{_libdir}/xorg/modules/input/gesture_drv.so
56 /usr/share/license/%{name}
57
58 %files devel
59 %{_libdir}/pkgconfig/xorg-gesture.pc