0a35398d1178874d4910d2824aaf3ae40a74f49f
[platform/adaptation/bluetooth-firmware-bcm.git] / packaging / bluetooth-firmware-bcm.spec
1 Name:      bluetooth-firmware-bcm
2 Summary:    firmware and tools for bluetooth
3 Version:    0.1.3
4 Release:    1
5 Group:      Hardware Support/Handset
6 License:    Apache
7 # NOTE: Source name does not match package name.  This should be
8 # resolved in the future, by I don't have that power. - Ryan Ware
9 Source0:    %{name}-%{version}.tar.gz
10
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  cmake
13
14 %description
15  firmware and tools for bluetooth
16
17 %package exynos3250
18 Summary:    bcm firmware and tools for exynos3250
19 Group:      Hardware Support/Handset
20
21 %description exynos3250
22 bcm firmware and tools for exynos3250
23
24 %package artik
25 Summary:    bcm firmware and tools for artik
26 Group:      Hardware Support/Handset
27
28 %description artik
29 bcm firmware and tools for artik
30
31 %prep
32 %setup -q
33
34 %build
35 cmake ./ -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPLUGIN_INSTALL_PREFIX=%{_prefix}
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40
41 %make_install
42
43 mkdir -p %{buildroot}/usr/share/license
44 cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
45 cat %{_builddir}/%{name}-%{version}/LICENSE.Broadcom >> %{buildroot}/usr/share/license/%{name}
46
47 %files
48 %defattr(-,root,root,-)
49 #%{_bindir}/bcmtool_4330b1
50 %exclude %{_bindir}/bcmtool_4343w
51 %{_bindir}/bcmtool_4358a1
52 %{_bindir}/setbd
53 #%{_prefix}/etc/bluetooth/BT_FW_BCM4330B1_002.001.003.0221.0265.hcd
54 %{_prefix}/etc/bluetooth/BT_FW_BCM4358A1_001.002.005.0032.0066.hcd
55 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
56 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
57 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
58
59 %files exynos3250
60 %defattr(-,root,root,-)
61 %{_bindir}/bcmtool_4343w
62 %{_bindir}/setbd
63 %{_prefix}/etc/bluetooth/BCM4343A1_001.002.009.0035.0096_ORC_Orbis_WC1-S.hcd
64 %{_prefix}/etc/bluetooth/BCM4343A1_001.002.009.0022.0050_Murata_Type-1FR.hcd
65 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
66 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-exynos3250.sh
67 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
68 /usr/share/license/%{name}
69
70 %post artik
71 rm -rf %{_prefix}/etc/bluetooth/bt-dev-start.sh
72 ln -s %{_prefix}/etc/bluetooth/bt-dev-start-artik.sh %{_prefix}/etc/bluetooth/bt-dev-start.sh
73
74 %files artik
75 %defattr(644,root,root,-)
76 %{_bindir}/brcm_patchram_plus
77 %{_bindir}/setbd
78 %{_prefix}/etc/bluetooth/BCM4354_003.001.012.0353.0745_Samsung_Artik_ORC.hcd
79 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
80 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-artik.sh
81 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
82 /usr/share/license/%{name}