for callback invoke when resolution is changed
[platform/adaptation/ap_samsung/libomxil-e3250-v4l2.git] / packaging / libomxil-e3250-v4l2.spec
1 Name: libomxil-e3250-v4l2
2 Summary: OpenMAX IL for e3250-v4l2
3 Version: 0.1.3
4 License: Apache-2.0
5 Group: Development/Libraries
6 Release: 0
7 ExclusiveArch: %arm
8 Source: %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 #!BuildIgnore: kernel-headers
12 BuildConflicts: linux-glibc-devel
13 BuildRequires: kernel-headers-3.4-exynos3250
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(mm-common)
16
17 %description
18 implementation of OpenMAX IL for e3250-v4l2 for B2
19
20
21 %package devel
22 Summary: OpenMAX IL for e3250-v4l2 (Developement)
23 Group: Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25
26 %description devel
27 development package for libomxil-e3250-v4l2
28
29 %prep
30 %setup -q
31
32 %build
33 ./autogen.sh
34
35 export CFLAGS+="\
36 %ifnarch aarch64
37  -mfpu=neon\
38  -DUSE_NEON\
39 %endif
40  -DUSE_PB\
41  -DUSE_DMA_BUF\
42  -DUSE_H264_PREPEND_SPS_PPS\
43  -DGST_EXT_TIME_ANALYSIS"
44
45 export LDFLAGS+="-Wl,--rpath=%{_prefix} -Wl,--as-needed,-z,noexecstack"
46
47 %ifnarch aarch64
48 %configure --prefix=%{_prefix} --disable-static --enable-dlog --enable-exynos3250 --enable-neon
49 %else
50 %configure --prefix=%{_prefix} --disable-static --enable-dlog --enable-exynos3250 --disable-neon
51 %endif
52
53 #make %{?jobs:-j%jobs}
54 make
55
56
57 %install
58 rm -rf %{buildroot}
59 mkdir -p %{buildroot}/usr/share/license
60 cp COPYING %{buildroot}/usr/share/license/%{name}
61 %make_install
62
63
64 %post -p /sbin/ldconfig
65
66 %postun -p /sbin/ldconfig
67
68
69 %files
70 %manifest libomxil-e3250-v4l2.manifest
71 %{_libdir}/*.so*
72 %{_libdir}/omx/*.so
73 %{_datadir}/license/%{name}
74
75
76 %files devel
77 /usr/include/*
78 %{_libdir}/pkgconfig/*
79