Updating license in spec file
[pkgs/u/ui-gadget.git] / packaging / ui-gadget.spec
1
2 Name:       ui-gadget
3 Summary:    UI Gadget Library
4 Version:    0.1.3
5 Release:    66
6 Group:      TO_BE/FILLED_IN
7 License:    Flora Sofrware License
8 Source0:    ui-gadget-%{version}.tar.gz
9 Source1001: packaging/ui-gadget.manifest 
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(utilX)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(appcore-efl)
15 BuildRequires:  pkgconfig(bundle)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(x11)
18 BuildRequires:  cmake
19 BuildRequires:  edje-bin
20
21
22 %description
23 UI gadget library (development headers)
24
25
26 %package devel
27 Summary:    Development files for %{name}
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30 %description devel
31 Development files for %{name}
32
33
34
35
36 %prep
37 %setup -q
38
39
40 %build
41 cp %{SOURCE1001} .
42 cmake . -DCMAKE_INSTALL_PREFIX=/usr
43
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50
51
52
53
54 %post -p /sbin/ldconfig
55
56 %postun -p /sbin/ldconfig
57
58
59
60
61
62
63
64
65 %files
66 %manifest ui-gadget.manifest
67 %defattr(-,root,root,-)
68 %{_libdir}/*.so.*
69 %{_libdir}/libug-efl-engine.so
70 /usr/share/edje/ug_effect.edj
71
72 %files devel
73 %manifest ui-gadget.manifest
74 %defattr(-,root,root,-)
75 %{_includedir}/*.h
76 %{_libdir}/*.so
77 %{_libdir}/pkgconfig/ui-gadget.pc
78