upload tizen1.0 source
[pkgs/o/oma-ds-service.git] / packaging / oma-ds-service.spec
1 Name:       oma-ds-service
2 Summary:    oma-ds-service
3 Version:    0.1.11
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Samsung Proprietary License
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(libsoup-2.4)
12 BuildRequires:  pkgconfig(sqlite3)
13 BuildRequires:  pkgconfig(sync-agent-framework)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(libwbxml2)
16 BuildRequires:  pkgconfig(check)
17 BuildRequires:  expat-devel
18 BuildRequires:  cmake
19
20 Requires(post): /sbin/ldconfig  
21 Requires(postun): /sbin/ldconfig  
22
23
24 %description
25 oma-ds-service daemon (development headers)
26
27
28 #%package devel
29 #Summary:    Development files for %{name}
30 #Group:      Development/Libraries
31 #Requires:   %{name} = %{version}-%{release}
32 #%description devel
33 #Development files for %{name}
34
35 %prep
36 %setup -q
37
38
39 %build
40 cmake . -DCMAKE_INSTALL_PREFIX=/usr
41
42
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 %make_install
48
49 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d    
50 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d    
51 mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc5.d    
52 mv syncmld_mgr %{buildroot}%{_sysconfdir}/rc.d/init.d/syncmld_mgr    
53   
54 ln -s %{_sysconfdir}/rc.d/init.d/syncmld_mgr %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S90Syncmld  
55 ln -s %{_sysconfdir}/rc.d/init.d/syncmld_mgr %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S90Syncmld  
56
57 mkdir -p %{buildroot}/opt/data/oma-ds  
58 mv eventconfig_omads %{buildroot}/opt/data/oma-ds/  
59 mv noticonfig_omads %{buildroot}/opt/data/oma-ds/  
60 mv omadsUI_fw_config.xml %{buildroot}/opt/data/oma-ds/  
61 mv omads_fw_config.xml %{buildroot}/opt/data/oma-ds/
62
63 %post -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(-,root,root,-)
68 %{_bindir}/*
69 #/opt/data/eventconfig_omads
70 #/opt/data/noticonfig_omads
71 /opt/data/oma-ds/eventconfig_omads  
72 /opt/data/oma-ds/noticonfig_omads  
73 /opt/data/oma-ds/omadsUI_fw_config.xml  
74 /opt/data/oma-ds/omads_fw_config.xml  
75
76
77 %defattr(700,root,root)    
78 %{_sysconfdir}/rc.d/init.d/syncmld_mgr    
79   
80 #%files devel
81 #%defattr(-,root,root,-)
82 #%{_includedir}/agent-framework/*
83 #%{_libdir}/*.so
84 #%{_libdir}/pkgconfig/oma-ds-service.pc
85
86 %defattr(755,root,root)      
87 %{_sysconfdir}/rc.d/rc3.d/S90Syncmld       
88 %{_sysconfdir}/rc.d/rc5.d/S90Syncmld