Add default Smack manifest for native-installer.spec 2.0alpha master
authorRyan Ware <ryan.r.ware@intel.com>
Wed, 30 May 2012 00:50:48 +0000 (17:50 -0700)
committerRyan Ware <ryan.r.ware@intel.com>
Wed, 30 May 2012 00:50:48 +0000 (17:50 -0700)
Change-Id: Ib4861204b51c1001d6e65902a4916a229af0d4dd
Signed-off-by: Ryan Ware <ryan.r.ware@intel.com>
packaging/native-installer.manifest [new file with mode: 0644]
packaging/native-installer.spec [changed mode: 0755->0644]

diff --git a/packaging/native-installer.manifest b/packaging/native-installer.manifest
new file mode 100644 (file)
index 0000000..017d22d
--- /dev/null
@@ -0,0 +1,5 @@
+<manifest>
+ <request>
+    <domain name="_"/>
+ </request>
+</manifest>
old mode 100755 (executable)
new mode 100644 (file)
index e955233..e8ee50b
@@ -5,6 +5,7 @@ Release:    1
 Group:      System/Libraries
 License:    Apache License, Version 2.0
 Source0:    %{name}-%{version}.tar.gz
+Source1001: packaging/native-installer.manifest 
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  cmake
@@ -33,6 +34,7 @@ Native debian installer
 %setup -q
 
 %build
+cp %{SOURCE1001} .
 CFLAGS+=" -fpic"
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
 
@@ -56,6 +58,7 @@ chmod 755 /usr/lib/native-installer/libnative-util.a
 chmod 755 /usr/bin/native-backend
 
 %files
+%manifest native-installer.manifest
 /usr/bin/native-backend
 /usr/bin/install_spk.sh
 /usr/bin/audit_spk.sh