Add default Smack manifest for elektra.spec
[pkgs/e/elektra.git] / packaging / elektra.spec
1 Name:       elektra
2 Summary:    A key/value pair database to store software configurations
3 Version: 0.7.0
4 Release:    42
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://elektra.sourceforge.net
8 Source0:    %{name}-%{version}.tar.gz
9 Source1001: packaging/elektra.manifest 
10 #Patch0:     fix-autogen-failure.patch
11 #Patch1:        static.patch
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 BuildRequires:  pkgconfig(libxml-2.0)
15 BuildRequires:  gettext-devel
16 BuildRequires:  libtool-ltdl-devel
17
18
19 %description
20 A framework to get system and user values The objective of the Elektra Project is to help create a pervasive, 
21  ubiquitous configuration system. This is an entire ecosystem, much
22  more than a piece of code. This section lists the work of some 
23  people that are helping to build it.
24
25
26 %package devel
27 Summary:    Framework to get system and user values
28 Group:      Development/Libraries
29
30
31 %description devel
32 Framework to get system and user values, key/value pair database
33
34
35 %prep
36 %setup -q
37
38 # fix-autogen-failure.patch
39 #%patch0 -p1
40 #%patch1 -p1
41
42 %build
43 cp %{SOURCE1001} .
44 export CFLAGS+="  -fno-short-enums -DSQLFS_BACKEND -DTUNNING_ELEKTRA_0_7 -fpic"
45 touch config.rpath
46
47 autoheader
48 libtoolize --ltdl --copy --force
49 aclocal -Im4 -Ilibltdl
50 autoconf
51 automake --add-missing --copy --force
52
53 ./configure --prefix=%{_prefix} \
54     --without-docbook \
55     --without-libltdl \
56     --enable-cpp=no \
57     --enable-hosts=no \
58     --enable-shared=no
59
60 make %{?jobs:-j%jobs}
61
62 %install
63 rm -rf %{buildroot}
64 %makeinstall
65
66 rm -rf %{buildroot}/usr/lib/libelektra.so*
67 rm -rf %{buildroot}/usr/lib/elektra/
68 rm -rf %{buildroot}/usr/lib/pkgconfig/elektracpp.pc
69 rm -rf %{buildroot}/usr/lib/pkgconfig/elektratools.pc
70
71 %post -p /sbin/ldconfig
72
73 %postun -p /sbin/ldconfig
74
75 %files devel
76 %manifest elektra.manifest
77 %defattr(-,root,root,-)
78 %{_includedir}/*.h
79 %{_libdir}/pkgconfig/elektra.pc
80 %{_libdir}/*.a
81 %{_libdir}/*.la