Git init
[pkgs/e/elektra.git] / packaging / elektra.spec
1
2 Name:       elektra
3 Summary:    A key/value pair database to store software configurations
4 Version:    0.7.0
5 Release:    1
6 Group:      System/Libraries
7 License:    BSD
8 URL:        http://elektra.sourceforge.net
9 Source0:    elektra-%{version}.tar.gz
10 Patch0:     fix-autogen-failure.patch
11 Patch1:         static.patch
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 BuildRequires:  pkgconfig(libxml-2.0)
15 BuildRequires:  gettext-devel
16 BuildRequires:  libtool-ltdl-devel
17
18
19 %description
20 A framework to get system and user values The objective of the Elektra Project is to help create a pervasive, 
21  ubiquitous configuration system. This is an entire ecosystem, much
22  more than a piece of code. This section lists the work of some 
23  people that are helping to build it.
24
25
26
27 %package devel
28 Summary:    Framework to get system and user values
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 Framework to get system and user values, key/value pair database
34
35
36 %prep
37 %setup -q -n %{name}
38
39 # fix-autogen-failure.patch
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 export CFLAGS+="  -fno-short-enums -DSQLFS_BACKEND -DTUNNING_ELEKTRA_0_7 -fpic"
45 touch config.rpath
46
47 %autogen --disable-static
48 %configure \
49     --disable-static \
50     --without-docbook \
51     --enable-cpp=no \
52     --enable-hosts=no \
53     --enable-shared=yes
54
55 make %{?jobs:-j%jobs}
56
57 %install
58 rm -rf %{buildroot}
59 %makeinstall
60
61
62 rm -rf %{buildroot}/usr/lib/*.la
63 rm -rf %{buildroot}/usr/lib/elektra/*.la
64
65 pushd %{buildroot}/usr/lib
66 ln -s elektra/libelektra-ddefault.so
67 ln -s elektra/libelektra-default.so
68 ln -s elektra/libelektra-filesys.so
69 popd
70
71
72 %post -p /sbin/ldconfig
73
74 %postun -p /sbin/ldconfig
75
76
77
78
79
80 %files
81 %defattr(-,root,root,-)
82 %doc COPYING
83 %{_libdir}/*.so.*
84 %{_libdir}/libelektra-*.so
85 %{_libdir}/elektra/*.so.*
86 %{_libdir}/elektra/*.so
87
88 %files devel
89 %defattr(-,root,root,-)
90 %{_includedir}/*.h
91 %{_libdir}/pkgconfig/*.pc
92 %{_libdir}/libelektra.so
93 %{_libdir}/*.a