fix arm build issue
[framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.47
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 %ifarch %{arm}
10 BuildRequires:  nodejs-x86-arm
11 %else
12 BuildRequires:  nodejs
13 %endif
14
15 Source0:    %{name}-%{version}.tar.gz
16
17 %description
18 Tizen Web UI Framework library and theme packages
19
20 %prep
21 %setup -q
22
23 %build
24 make all
25
26 %install
27 make DESTDIR=%{buildroot} install
28
29 %post
30
31 %files
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-black
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-black
46 %Description -n web-ui-fw-theme-tizen-black
47     Tizen Web UI Framework Theme : tizen-black
48 %files -n web-ui-fw-theme-tizen-black
49 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
50
51 ###############################
52 %package -n web-ui-fw-theme-tizen-white
53 BuildArch:  noarch
54 Summary:    Tizen Web UI Framework Theme : tizen-white
55 %Description -n web-ui-fw-theme-tizen-white
56     Tizen Web UI Framework Theme : tizen-white
57 %files -n web-ui-fw-theme-tizen-white
58 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
59
60 ###############################
61 %package -n web-ui-fw-theme-default
62 BuildArch:  noarch
63 Summary:    Tizen Web UI Framework Theme : default
64 %Description -n web-ui-fw-theme-default
65     Tizen Web UI Framework Theme : default
66 %files -n web-ui-fw-theme-default
67 /usr/share/tizen-web-ui-fw/*/themes/default
68
69 ###############################
70 %package -n web-ui-fw-devel
71 BuildArch:  noarch
72 Summary:    Tizen Web UI Framework Developer's files
73 %Description -n web-ui-fw-devel
74     Tizen Web UI Framework Developer's files
75 %files -n web-ui-fw-devel
76 /usr/share/tizen-web-ui-fw/bin
77 /usr/share/tizen-web-ui-fw/template
78
79 ###############################
80 %package -n web-ui-fw-demo-tizen-winsets
81 BuildArch:  noarch
82 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
83 %Description -n web-ui-fw-demo-tizen-winsets
84     Tizen Web UI Framework Demo Application: tizen winset demo
85 %files  -n web-ui-fw-demo-tizen-winsets
86 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
87
88
89 ###############################
90 %changelog
91
92 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
93 - FIX:
94         - scrollveiw: fix height of view
95         - searchbar: support placeholder
96 - Spec changes:
97         - add ui-text-ellipsis class
98
99 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
100 - FIX:
101         - scrollview: scrolling bug fix
102         - controlbar: fix width of controlbar item
103 - Spec changes:
104         - searchbar: don't hide icon
105         - popup: update JQM poup widget
106
107 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
108 - FIX:
109         - controlbar: set correct controlbar width of last element
110         - slider: get popup enable value correctly
111         - use Date.now() instead of (new Data()).getTime()
112         - popupwindow: fix the background color of popup scroller
113         - listview: add padding-left to expandable list
114         - add ellipsis for title area support
115
116 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
117 - FIX:
118         - swipelist: show list items correctly
119         - datetimepicker: set last day, if day is overflowed
120 - Spec changes:
121         - controlbar: update icons
122
123 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
124 - FIX:
125         - notification: fix typo
126 - Spec changes:
127         - controlbar: update icons
128
129 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
130 - FIX:
131         - multimediaview: video progress bar display normally for too samll
132         - segmentcontrol: remove media query
133         - scrollview: add outer scroll condition
134         - datetimepicker: modify triangle size
135         - popupwindow: set the screen height explicitly
136         - notification: add multiline text
137 - Spec changes:
138         - mutibuttonentry: support new GUI
139         - virtualgrid: support new GUI
140
141 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
142 - FIX:
143         - radio/check button : button size bug fix
144
145 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
146 - FIX:
147         - build error fixed
148
149 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
150 - FIX:
151         - listview: style fix, remove filter placeholder
152         - controlbar: divide styles
153         - scrollview: don't skip dragging when click button or inputbox
154         - slider: trim the text on text slider
155 - Spec changes:
156         - remove gray and blue theme
157         - add white and black theme
158         - support new GUI guide
159
160 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
161 - FIX:
162         - fix coment of version tag
163
164 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
165 - FIX :
166         - button: fix alignment
167         - listview: adjust the main text width
168         - virtualgrid: refactoring
169 - Spec changes:
170         - transition: support JQM 1.1.0 transitions
171         - scrollview: support the outer scroll
172         - notification: remove interval feature
173
174 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
175 - FIX :
176         - checkboxRadio: Add left/right padding
177         - button: custom button & icon position
178         - virtuallist: remove 'recreate' test
179 - Spec changes:
180         - header/footer: enable/disable support
181
182 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
183 - FIX :
184         - expandablelist: modify show animation
185         - virtualgrid: Redesign programming interface
186         - popupwindow: code clean and fixed issues
187         - pagelayout: fix content height
188         - license file update
189         - virtuallist: Change programming interface
190         - datetimepicker: getting days correctly
191         - searchbar: set to hidden when cancel button is hide
192         - White theme title font tuning
193 - Spec changes:
194         - default theme tizen-gray to tizen-white
195         - set default page transition to none
196
197 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
198 - FIX :
199         - Back Button : enlarge backbutton click size for white theme
200 - Feature :
201         - Expandable List : Add refresh api
202 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
203 - FIX :
204         - click event touch threshold tuning
205
206 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
207 - FIX : 
208         - Add back button highlight effect for white theme
209
210 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
211 - FIX : 
212         - IME checkroutine update, improve relayout on resize event
213         - Add highlight effect for radio button list 
214         - Scrollview : fix condition of updatelayout event
215 - Feature : progressing : add show/hide api
216
217 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
218 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
219         add default theme option on buttonMarkup for tizen theme
220         [searchbar] first fix : focus/blur fixed
221         back button does not work when long press
222         scrollview: don't auto scrolling if resizing area is too large
223 - Feature : notification : add api to set the icon at tickernoti
224         demo : update the list sample demo
225         Support tizen default theme
226
227 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
228 - Improvements & Bugfixes
229    - HOTFIX: Revert template function with jquery.template
230
231 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
232 - Improvements & Bugfixes
233    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
234 - Spec changes
235    - $.tizen.loadTheme() function accepts theme name as arguement
236    - Scrollview supports 'updatelayout' callback
237
238 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
239 - Improvements & Bugfixes
240    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
241
242 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
243 - Improvements & Bugfixes
244    - Add tizen-white theme package, to make rpm build to be finished
245
246 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
247 - Improvements & Bugfixes
248    - Set 'slide' as default page transition effect, by JQM patch
249
250 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
251 - Improvements & Bugfixes
252    - Fix IME show/hide algorithm
253    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
254
255 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
256 - Improvements & Bugfixes
257    - Fix notification position
258    - Fix unit tests
259
260  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
261 - Spec changes
262         - JQM 1.1 upgrade
263 - Improvements & Bugfixes
264         - Transform3D support on scrollview
265         - Page layout supports IME control
266         - Mapview supports pinch zoom on JQM 1.1
267         - Fix wrong character on button in minified version
268         - Virtualgrid supports scrollbar
269         - Lots of bugfixes
270
271 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
272 - Spec changes
273         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
274         - imageslider : supports 'resize' event.
275         - listview : listview has 1px padding-bottom.
276         - loader : Change global namespace, from S to $.tizen.
277         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
278 - Improvements & Bugfixes
279         - Scrollview : supports 'translate3d', instead of 'translate'.
280         - notification : reset timer when 'show' or 'refresh' event.
281         - JQM patch : Fix vclick event triggered twice.
282 - Etc.
283         - Add & fix unit tests.
284
285 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
286 - Spec changes
287         - mapview : new widget.
288         - notification : add .refresh() API.
289         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
290 - Improvements & Bugfixes
291         - Support minified CSS.
292         - loader : Fix & refactor 'loading globalize culture file' routine.
293         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
294         - Many more bugfixes.
295 - Etc.
296         - Add many unit tests.
297         - Fix test coverage instrumentation tool to work with current source code.