42b2a07bfc2f4d4231bfe66f1ce965d482ea3147
[framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.47
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  node-js
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 /usr/share/tizen-web-ui-fw/*/js
32 /usr/share/tizen-web-ui-fw/latest
33
34 ###############################
35 %package -n web-ui-fw-theme-tizen-gray
36 BuildArch:  noarch
37 Summary:    Tizen Web UI Framework Theme : tizen-gray
38 %Description -n web-ui-fw-theme-tizen-gray
39     Tizen Web UI Framework Theme : tizen-gray
40
41 ###############################
42 %package -n web-ui-fw-theme-tizen-black
43 BuildArch:  noarch
44 Summary:    Tizen Web UI Framework Theme : tizen-black
45 %Description -n web-ui-fw-theme-tizen-black
46     Tizen Web UI Framework Theme : tizen-black
47 %files -n web-ui-fw-theme-tizen-black
48 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
49
50 ###############################
51 %package -n web-ui-fw-theme-tizen-white
52 BuildArch:  noarch
53 Summary:    Tizen Web UI Framework Theme : tizen-white
54 %Description -n web-ui-fw-theme-tizen-white
55     Tizen Web UI Framework Theme : tizen-white
56 %files -n web-ui-fw-theme-tizen-white
57 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
58
59 ###############################
60 %package -n web-ui-fw-theme-default
61 BuildArch:  noarch
62 Summary:    Tizen Web UI Framework Theme : default
63 %Description -n web-ui-fw-theme-default
64     Tizen Web UI Framework Theme : default
65 %files -n web-ui-fw-theme-default
66 /usr/share/tizen-web-ui-fw/*/themes/default
67
68 ###############################
69 %package -n web-ui-fw-devel
70 BuildArch:  noarch
71 Summary:    Tizen Web UI Framework Developer's files
72 %Description -n web-ui-fw-devel
73     Tizen Web UI Framework Developer's files
74 %files -n web-ui-fw-devel
75 /usr/share/tizen-web-ui-fw/bin
76 /usr/share/tizen-web-ui-fw/template
77
78 ###############################
79 %package -n web-ui-fw-demo-tizen-winsets
80 BuildArch:  noarch
81 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
82 %Description -n web-ui-fw-demo-tizen-winsets
83     Tizen Web UI Framework Demo Application: tizen winset demo
84 %files  -n web-ui-fw-demo-tizen-winsets
85 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
86
87
88 ###############################
89 %changelog
90
91 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
92 - FIX:
93         - scrollveiw: fix height of view
94         - searchbar: support placeholder
95 - Spec changes:
96         - add ui-text-ellipsis class
97
98 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
99 - FIX:
100         - scrollview: scrolling bug fix
101         - controlbar: fix width of controlbar item
102 - Spec changes:
103         - searchbar: don't hide icon
104         - popup: update JQM poup widget
105
106 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
107 - FIX:
108         - controlbar: set correct controlbar width of last element
109         - slider: get popup enable value correctly
110         - use Date.now() instead of (new Data()).getTime()
111         - popupwindow: fix the background color of popup scroller
112         - listview: add padding-left to expandable list
113         - add ellipsis for title area support
114
115 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
116 - FIX:
117         - swipelist: show list items correctly
118         - datetimepicker: set last day, if day is overflowed
119 - Spec changes:
120         - controlbar: update icons
121
122 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
123 - FIX:
124         - notification: fix typo
125 - Spec changes:
126         - controlbar: update icons
127
128 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
129 - FIX:
130         - multimediaview: video progress bar display normally for too samll
131         - segmentcontrol: remove media query
132         - scrollview: add outer scroll condition
133         - datetimepicker: modify triangle size
134         - popupwindow: set the screen height explicitly
135         - notification: add multiline text
136 - Spec changes:
137         - mutibuttonentry: support new GUI
138         - virtualgrid: support new GUI
139
140 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
141 - FIX:
142         - radio/check button : button size bug fix
143
144 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
145 - FIX:
146         - build error fixed
147
148 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
149 - FIX:
150         - listview: style fix, remove filter placeholder
151         - controlbar: divide styles
152         - scrollview: don't skip dragging when click button or inputbox
153         - slider: trim the text on text slider
154 - Spec changes:
155         - remove gray and blue theme
156         - add white and black theme
157         - support new GUI guide
158
159 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
160 - FIX:
161         - fix coment of version tag
162
163 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
164 - FIX :
165         - button: fix alignment
166         - listview: adjust the main text width
167         - virtualgrid: refactoring
168 - Spec changes:
169         - transition: support JQM 1.1.0 transitions
170         - scrollview: support the outer scroll
171         - notification: remove interval feature
172
173 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
174 - FIX :
175         - checkboxRadio: Add left/right padding
176         - button: custom button & icon position
177         - virtuallist: remove 'recreate' test
178 - Spec changes:
179         - header/footer: enable/disable support
180
181 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
182 - FIX :
183         - expandablelist: modify show animation
184         - virtualgrid: Redesign programming interface
185         - popupwindow: code clean and fixed issues
186         - pagelayout: fix content height
187         - license file update
188         - virtuallist: Change programming interface
189         - datetimepicker: getting days correctly
190         - searchbar: set to hidden when cancel button is hide
191         - White theme title font tuning
192 - Spec changes:
193         - default theme tizen-gray to tizen-white
194         - set default page transition to none
195
196 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
197 - FIX :
198         - Back Button : enlarge backbutton click size for white theme
199 - Feature :
200         - Expandable List : Add refresh api
201 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
202 - FIX :
203         - click event touch threshold tuning
204
205 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
206 - FIX : 
207         - Add back button highlight effect for white theme
208
209 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
210 - FIX : 
211         - IME checkroutine update, improve relayout on resize event
212         - Add highlight effect for radio button list 
213         - Scrollview : fix condition of updatelayout event
214 - Feature : progressing : add show/hide api
215
216 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
217 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
218         add default theme option on buttonMarkup for tizen theme
219         [searchbar] first fix : focus/blur fixed
220         back button does not work when long press
221         scrollview: don't auto scrolling if resizing area is too large
222 - Feature : notification : add api to set the icon at tickernoti
223         demo : update the list sample demo
224         Support tizen default theme
225
226 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
227 - Improvements & Bugfixes
228    - HOTFIX: Revert template function with jquery.template
229
230 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
231 - Improvements & Bugfixes
232    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
233 - Spec changes
234    - $.tizen.loadTheme() function accepts theme name as arguement
235    - Scrollview supports 'updatelayout' callback
236
237 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
238 - Improvements & Bugfixes
239    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
240
241 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
242 - Improvements & Bugfixes
243    - Add tizen-white theme package, to make rpm build to be finished
244
245 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
246 - Improvements & Bugfixes
247    - Set 'slide' as default page transition effect, by JQM patch
248
249 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
250 - Improvements & Bugfixes
251    - Fix IME show/hide algorithm
252    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
253
254 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
255 - Improvements & Bugfixes
256    - Fix notification position
257    - Fix unit tests
258
259  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
260 - Spec changes
261         - JQM 1.1 upgrade
262 - Improvements & Bugfixes
263         - Transform3D support on scrollview
264         - Page layout supports IME control
265         - Mapview supports pinch zoom on JQM 1.1
266         - Fix wrong character on button in minified version
267         - Virtualgrid supports scrollbar
268         - Lots of bugfixes
269
270 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
271 - Spec changes
272         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
273         - imageslider : supports 'resize' event.
274         - listview : listview has 1px padding-bottom.
275         - loader : Change global namespace, from S to $.tizen.
276         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
277 - Improvements & Bugfixes
278         - Scrollview : supports 'translate3d', instead of 'translate'.
279         - notification : reset timer when 'show' or 'refresh' event.
280         - JQM patch : Fix vclick event triggered twice.
281 - Etc.
282         - Add & fix unit tests.
283
284 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
285 - Spec changes
286         - mapview : new widget.
287         - notification : add .refresh() API.
288         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
289 - Improvements & Bugfixes
290         - Support minified CSS.
291         - loader : Fix & refactor 'loading globalize culture file' routine.
292         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
293         - Many more bugfixes.
294 - Etc.
295         - Add many unit tests.
296         - Fix test coverage instrumentation tool to work with current source code.