2db3408fcbcf6d7abb93c5058b7f6ba026e435c4
[framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.45
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 /usr/share/tizen-web-ui-fw/*/js
32 /usr/share/tizen-web-ui-fw/latest
33
34 ###############################
35 %package -n web-ui-fw-theme-tizen-gray
36 BuildArch:  noarch
37 Summary:    Tizen Web UI Framework Theme : tizen-gray
38 %Description -n web-ui-fw-theme-tizen-gray
39     Tizen Web UI Framework Theme : tizen-gray
40
41 ###############################
42 %package -n web-ui-fw-theme-tizen-black
43 BuildArch:  noarch
44 Summary:    Tizen Web UI Framework Theme : tizen-black
45 %Description -n web-ui-fw-theme-tizen-black
46     Tizen Web UI Framework Theme : tizen-black
47 %files -n web-ui-fw-theme-tizen-black
48 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
49
50 ###############################
51 %package -n web-ui-fw-theme-tizen-white
52 BuildArch:  noarch
53 Summary:    Tizen Web UI Framework Theme : tizen-white
54 %Description -n web-ui-fw-theme-tizen-white
55     Tizen Web UI Framework Theme : tizen-white
56 %files -n web-ui-fw-theme-tizen-white
57 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
58
59 ###############################
60 %package -n web-ui-fw-theme-default
61 BuildArch:  noarch
62 Summary:    Tizen Web UI Framework Theme : default
63 %Description -n web-ui-fw-theme-default
64     Tizen Web UI Framework Theme : default
65 %files -n web-ui-fw-theme-default
66 /usr/share/tizen-web-ui-fw/*/themes/default
67
68 ###############################
69 %package -n web-ui-fw-devel
70 BuildArch:  noarch
71 Summary:    Tizen Web UI Framework Developer's files
72 %Description -n web-ui-fw-devel
73     Tizen Web UI Framework Developer's files
74 %files -n web-ui-fw-devel
75 /usr/share/tizen-web-ui-fw/bin
76 /usr/share/tizen-web-ui-fw/template
77
78 ###############################
79 %package -n web-ui-fw-demo-tizen-winsets
80 BuildArch:  noarch
81 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
82 %Description -n web-ui-fw-demo-tizen-winsets
83     Tizen Web UI Framework Demo Application: tizen winset demo
84 %files  -n web-ui-fw-demo-tizen-winsets
85 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
86
87
88 ###############################
89 %changelog
90
91 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
92 - FIX:
93         - controlbar: set correct controlbar width of last element
94         - slider: get popup enable value correctly
95         - use Date.now() instead of (new Data()).getTime()
96         - popupwindow: fix the background color of popup scroller
97         - listview: add padding-left to expandable list
98         - add ellipsis for title area support
99
100 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
101 - FIX:
102         - swipelist: show list items correctly
103         - datetimepicker: set last day, if day is overflowed
104 - Spec changes:
105         - controlbar: update icons
106
107 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
108 - FIX:
109         - notification: fix typo
110 - Spec changes:
111         - controlbar: update icons
112
113 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
114 - FIX:
115         - multimediaview: video progress bar display normally for too samll
116         - segmentcontrol: remove media query
117         - scrollview: add outer scroll condition
118         - datetimepicker: modify triangle size
119         - popupwindow: set the screen height explicitly
120         - notification: add multiline text
121 - Spec changes:
122         - mutibuttonentry: support new GUI
123         - virtualgrid: support new GUI
124
125 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
126 - FIX:
127         - radio/check button : button size bug fix
128
129 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
130 - FIX:
131         - build error fixed
132
133 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
134 - FIX:
135         - listview: style fix, remove filter placeholder
136         - controlbar: divide styles
137         - scrollview: don't skip dragging when click button or inputbox
138         - slider: trim the text on text slider
139 - Spec changes:
140         - remove gray and blue theme
141         - add white and black theme
142         - support new GUI guide
143
144 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
145 - FIX:
146         - fix coment of version tag
147
148 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
149 - FIX :
150         - button: fix alignment
151         - listview: adjust the main text width
152         - virtualgrid: refactoring
153 - Spec changes:
154         - transition: support JQM 1.1.0 transitions
155         - scrollview: support the outer scroll
156         - notification: remove interval feature
157
158 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
159 - FIX :
160         - checkboxRadio: Add left/right padding
161         - button: custom button & icon position
162         - virtuallist: remove 'recreate' test
163 - Spec changes:
164         - header/footer: enable/disable support
165
166 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
167 - FIX :
168         - expandablelist: modify show animation
169         - virtualgrid: Redesign programming interface
170         - popupwindow: code clean and fixed issues
171         - pagelayout: fix content height
172         - license file update
173         - virtuallist: Change programming interface
174         - datetimepicker: getting days correctly
175         - searchbar: set to hidden when cancel button is hide
176         - White theme title font tuning
177 - Spec changes:
178         - default theme tizen-gray to tizen-white
179         - set default page transition to none
180
181 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
182 - FIX :
183         - Back Button : enlarge backbutton click size for white theme
184 - Feature :
185         - Expandable List : Add refresh api
186 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
187 - FIX :
188         - click event touch threshold tuning
189
190 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
191 - FIX : 
192         - Add back button highlight effect for white theme
193
194 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
195 - FIX : 
196         - IME checkroutine update, improve relayout on resize event
197         - Add highlight effect for radio button list 
198         - Scrollview : fix condition of updatelayout event
199 - Feature : progressing : add show/hide api
200
201 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
202 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
203         add default theme option on buttonMarkup for tizen theme
204         [searchbar] first fix : focus/blur fixed
205         back button does not work when long press
206         scrollview: don't auto scrolling if resizing area is too large
207 - Feature : notification : add api to set the icon at tickernoti
208         demo : update the list sample demo
209         Support tizen default theme
210
211 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
212 - Improvements & Bugfixes
213    - HOTFIX: Revert template function with jquery.template
214
215 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
216 - Improvements & Bugfixes
217    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
218 - Spec changes
219    - $.tizen.loadTheme() function accepts theme name as arguement
220    - Scrollview supports 'updatelayout' callback
221
222 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
223 - Improvements & Bugfixes
224    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
225
226 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
227 - Improvements & Bugfixes
228    - Add tizen-white theme package, to make rpm build to be finished
229
230 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
231 - Improvements & Bugfixes
232    - Set 'slide' as default page transition effect, by JQM patch
233
234 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
235 - Improvements & Bugfixes
236    - Fix IME show/hide algorithm
237    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
238
239 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
240 - Improvements & Bugfixes
241    - Fix notification position
242    - Fix unit tests
243
244  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
245 - Spec changes
246         - JQM 1.1 upgrade
247 - Improvements & Bugfixes
248         - Transform3D support on scrollview
249         - Page layout supports IME control
250         - Mapview supports pinch zoom on JQM 1.1
251         - Fix wrong character on button in minified version
252         - Virtualgrid supports scrollbar
253         - Lots of bugfixes
254
255 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
256 - Spec changes
257         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
258         - imageslider : supports 'resize' event.
259         - listview : listview has 1px padding-bottom.
260         - loader : Change global namespace, from S to $.tizen.
261         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
262 - Improvements & Bugfixes
263         - Scrollview : supports 'translate3d', instead of 'translate'.
264         - notification : reset timer when 'show' or 'refresh' event.
265         - JQM patch : Fix vclick event triggered twice.
266 - Etc.
267         - Add & fix unit tests.
268
269 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
270 - Spec changes
271         - mapview : new widget.
272         - notification : add .refresh() API.
273         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
274 - Improvements & Bugfixes
275         - Support minified CSS.
276         - loader : Fix & refactor 'loading globalize culture file' routine.
277         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
278         - Many more bugfixes.
279 - Etc.
280         - Add many unit tests.
281         - Fix test coverage instrumentation tool to work with current source code.