0cb5ae8c9b7d1e2aca9054a2086d961316b3e365
[framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.38
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 /usr/share/tizen-web-ui-fw/*/js
32 /usr/share/tizen-web-ui-fw/latest
33
34 ###############################
35 %package -n web-ui-fw-theme-tizen-gray
36 BuildArch:  noarch
37 Summary:    Tizen Web UI Framework Theme : tizen-gray
38 %Description -n web-ui-fw-theme-tizen-gray
39     Tizen Web UI Framework Theme : tizen-gray
40 %files -n web-ui-fw-theme-tizen-gray
41 /usr/share/tizen-web-ui-fw/*/themes/tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
51
52 ###############################
53 %package -n web-ui-fw-theme-default
54 BuildArch:  noarch
55 Summary:    Tizen Web UI Framework Theme : default
56 %Description -n web-ui-fw-theme-default
57     Tizen Web UI Framework Theme : default
58 %files -n web-ui-fw-theme-default
59 /usr/share/tizen-web-ui-fw/*/themes/default
60
61 ###############################
62 %package -n web-ui-fw-devel
63 BuildArch:  noarch
64 Summary:    Tizen Web UI Framework Developer's files
65 %Description -n web-ui-fw-devel
66     Tizen Web UI Framework Developer's files
67 %files -n web-ui-fw-devel
68 /usr/share/tizen-web-ui-fw/bin
69 /usr/share/tizen-web-ui-fw/template
70
71 ###############################
72 %package -n web-ui-fw-demo-tizen-winsets
73 BuildArch:  noarch
74 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
75 %Description -n web-ui-fw-demo-tizen-winsets
76     Tizen Web UI Framework Demo Application: tizen winset demo
77 %files  -n web-ui-fw-demo-tizen-winsets
78 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
79
80
81 ###############################
82 %changelog
83
84 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samasung.com> 0.1.38
85 - FIX:
86         - fix coment of version tag
87
88 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samasung.com> 0.1.37
89 - FIX :
90         - button: fix alignment
91         - listview: adjust the main text width
92         - virtualgrid: refactoring
93 - Spec changes:
94         - transition: support JQM 1.1.0 transitions
95         - scrollview: support the outer scroll
96         - notification: remove interval feature
97
98 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
99 - FIX :
100         - checkboxRadio: Add left/right padding
101         - button: custom button & icon position
102         - virtuallist: remove 'recreate' test
103 - Spec changes:
104         - header/footer: enable/disable support
105
106 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
107 - FIX :
108         - expandablelist: modify show animation
109         - virtualgrid: Redesign programming interface
110         - popupwindow: code clean and fixed issues
111         - pagelayout: fix content height
112         - license file update
113         - virtuallist: Change programming interface
114         - datetimepicker: getting days correctly
115         - searchbar: set to hidden when cancel button is hide
116         - White theme title font tuning
117 - Spec changes:
118         - default theme tizen-gray to tizen-white
119         - set default page transition to none
120
121 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
122 - FIX :
123         - Back Button : enlarge backbutton click size for white theme
124 - Feature :
125         - Expandable List : Add refresh api
126 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
127 - FIX :
128         - click event touch threshold tuning
129
130 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
131 - FIX : 
132         - Add back button highlight effect for white theme
133
134 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
135 - FIX : 
136         - IME checkroutine update, improve relayout on resize event
137         - Add highlight effect for radio button list 
138         - Scrollview : fix condition of updatelayout event
139 - Feature : progressing : add show/hide api
140
141 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
142 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
143         add default theme option on buttonMarkup for tizen theme
144         [searchbar] first fix : focus/blur fixed
145         back button does not work when long press
146         scrollview: don't auto scrolling if resizing area is too large
147 - Feature : notification : add api to set the icon at tickernoti
148         demo : update the list sample demo
149         Support tizen default theme
150
151 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
152 - Improvements & Bugfixes
153    - HOTFIX: Revert template function with jquery.template
154
155 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
156 - Improvements & Bugfixes
157    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
158 - Spec changes
159    - $.tizen.loadTheme() function accepts theme name as arguement
160    - Scrollview supports 'updatelayout' callback
161
162 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
163 - Improvements & Bugfixes
164    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
165
166 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
167 - Improvements & Bugfixes
168    - Add tizen-white theme package, to make rpm build to be finished
169
170 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
171 - Improvements & Bugfixes
172    - Set 'slide' as default page transition effect, by JQM patch
173
174 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
175 - Improvements & Bugfixes
176    - Fix IME show/hide algorithm
177    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
178
179 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
180 - Improvements & Bugfixes
181    - Fix notification position
182    - Fix unit tests
183
184  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
185 - Spec changes
186         - JQM 1.1 upgrade
187 - Improvements & Bugfixes
188         - Transform3D support on scrollview
189         - Page layout supports IME control
190         - Mapview supports pinch zoom on JQM 1.1
191         - Fix wrong character on button in minified version
192         - Virtualgrid supports scrollbar
193         - Lots of bugfixes
194
195 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
196 - Spec changes
197         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
198         - imageslider : supports 'resize' event.
199         - listview : listview has 1px padding-bottom.
200         - loader : Change global namespace, from S to $.tizen.
201         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
202 - Improvements & Bugfixes
203         - Scrollview : supports 'translate3d', instead of 'translate'.
204         - notification : reset timer when 'show' or 'refresh' event.
205         - JQM patch : Fix vclick event triggered twice.
206 - Etc.
207         - Add & fix unit tests.
208
209 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
210 - Spec changes
211         - mapview : new widget.
212         - notification : add .refresh() API.
213         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
214 - Improvements & Bugfixes
215         - Support minified CSS.
216         - loader : Fix & refactor 'loading globalize culture file' routine.
217         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
218         - Many more bugfixes.
219 - Etc.
220         - Add many unit tests.
221         - Fix test coverage instrumentation tool to work with current source code.