upload tizen2.0 source
[framework/uifw/xorg/xcb/xcb-util.git] / packaging / xcb-util.spec
1 Name:    xcb-util
2 Summary: utility libraries for X C Binding
3 Version: 0.3.8
4 Release: slp.1.2
5 Group:   System/Libraries
6 License: MIT
7 URL:     http://xcb.freedesktop.org/
8 Source: %{name}-%{version}.tar.gz
9
10 BuildRequires: pkgconfig(xorg-macros)
11 BuildRequires: libxcb-devel >= 1.4, m4
12 BuildRequires: pkgconfig(xproto)
13 BuildRequires: gperf
14 Provides:       xcb-renderutil
15
16 %description
17 Description: %{summary}
18 The xcb-util module provides a number of libraries which sit on top of
19 libxcb, the core X protocol library, and some of the extension
20 libraries. These experimental libraries provide convenience functions
21 and interfaces which make the raw X protocol more usable. Some of the
22 libraries also provide client-side code which is not strictly part of
23 the X protocol but which have traditionally been provided by Xlib.
24
25 %package        devel
26 Summary:        Development and header files for xcb-util
27 Group:          System Environment/Libraries
28 Requires:       %{name} = %{version}-%{release}, pkgconfig
29
30 %description    devel
31 Development files for xcb-util.
32
33 %prep
34 %setup -q
35
36 %build
37
38 ./autogen.sh
39 %reconfigure --disable-static
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47 %post -p /sbin/ldconfig
48 %postun -p /sbin/ldconfig
49
50 %remove_docs
51
52 %clean
53 rm -rf %{buildroot}
54
55
56 %files
57 %defattr(-,root,root,-)
58 %{_libdir}/libxcb-util.so.0*
59
60 %files devel
61 %defattr(-,root,root,-)
62 %{_libdir}/pkgconfig/*.pc
63 %{_libdir}/*.so
64 %{_includedir}/xcb/*.h
65
66