03686cc7ea149ac6c1af19e1d235b450535f776a
[framework/uifw/xorg/util/x11-xkb-utils.git] / packaging / xorg-x11-xkb-utils.spec
1 Summary: X11 XKB utilities
2 Name: xorg-x11-xkb-utils
3 Version: 7.6
4 Release: 8
5 License: MIT/X11
6 Group: User Interface/X
7 URL: http://www.x.org
8 Source: %{name}-%{version}.tar.gz
9
10 BuildRequires: pkgconfig(xorg-macros)
11 BuildRequires: pkgconfig(x11)
12 BuildRequires: pkgconfig(xaw7)
13 BuildRequires: pkgconfig(xkbfile)
14 BuildRequires: pkgconfig(inputproto)
15 BuildRequires: byacc
16
17 %define DEF_SUBDIRS setxkbmap xkbcomp xkbevd xkbprint xkbutils
18
19 Provides: %{DEF_SUBDIRS}
20
21 %description
22 xkbutils contains a number of client-side utilities for XKB, the X11 keyboard extension.
23 setxkbmap is a tool to query and change the current XKB map.
24 xkbbell generates a bell event through the keyboard.
25 xkbcomp is a tool to compile XKB definitions into map files the server can use.
26 xkbevd is an experimental tool to listen for certain XKB events and execute defined triggers when actions occur.
27 xkbprint is a tool to generate an image with the physical representation of the keyboard as XKB sees it.
28 xkbvleds shows the changing status of keyboard LEDs.
29 xkbwatch shows the changing status of modifiers and LEDs.
30
31 %prep
32 %setup -q
33
34 %build
35 # Build all apps
36 {
37     for app in %{DEF_SUBDIRS}; do
38         pushd $app
39         autoreconf -i -v -f
40         ./configure --prefix=/usr --mandir=/usr/share/man \
41                     --infodir=/usr/share/info \
42                     --datadir=/opt/etc 
43         make
44         popd
45     done
46 }
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 # Install all apps
51 {
52    for app in %{DEF_SUBDIRS} ; do
53       pushd $app
54       make install DESTDIR=$RPM_BUILD_ROOT
55       popd
56    done
57 }
58
59 %remove_docs
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %{_bindir}/*