upload tizen2.0 source
[framework/uifw/xorg/proto/x11proto-xf86dga.git] / packaging / xorg-x11-proto-xf86dga.spec
1 Name:     xorg-x11-proto-xf86dga
2 Summary:  X.Org X11 Protocol xf86dgaproto
3 Version:  2.1
4 Release:  1
5 Group:    Development/System
6 License:  MIT
7 URL:      http://www.x.org
8 Source0:  %{name}-%{version}.tar.gz
9 Provides: xf86dgaproto
10
11 BuildRequires: pkgconfig
12 BuildRequires: pkgconfig(xorg-macros)
13
14 # some file to be intalled can be ignored when rpm generates packages
15 %define _unpackaged_files_terminate_build 0
16
17 %description
18 Description: %{summary}
19
20 %prep
21 %setup -q
22
23 %build
24
25 ./autogen.sh
26 %reconfigure --disable-static \
27              --libdir=%{_datadir} \
28              --without-xmlto
29
30 # Call make instruction with smp support
31 make %{?jobs:-j%jobs}
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36
37 %remove_docs
38
39 %clean
40 rm -rf %{buildroot}
41
42 %files
43 %defattr(-,root,root,-)
44 %{_includedir}/X11/extensions/*.h
45 %{_datadir}/pkgconfig/*.pc