b73b88026f44a51f3854c3dac2a42cf051cac583
[framework/uifw/xorg/lib/libxres.git] / packaging / libXres.spec
1 Summary: X-Resource extension client library
2 Name: libXres
3 Version: 1.0.6
4 Release: 1
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig(xext)
12 BuildRequires:  pkgconfig(resourceproto)
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires:  pkgconfig(xproto)
15
16 %description
17 X-Resource is an extension that allows a client to query
18 the X server about its usage of various resources.
19
20 %package devel
21 Summary: Development files for %{name}
22 Group: Development/Libraries
23 Requires: %{name} = %{version}-%{release}
24 Provides: libxres-devel
25
26 %description devel
27 X.Org X11 libXres development package
28
29 %prep
30 %setup -q
31
32 %build
33 %reconfigure --disable-static \
34                LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 mkdir -p %{buildroot}/usr/share/license
40 cp -af COPYING %{buildroot}/usr/share/license/%{name}
41 make install DESTDIR=$RPM_BUILD_ROOT
42
43 # We intentionally don't ship *.la files
44 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
45
46 %remove_docs
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post -p /sbin/ldconfig
52 %postun -p /sbin/ldconfig
53
54 %files
55 %defattr(-,root,root,-)
56 /usr/share/license/%{name}
57 %doc AUTHORS COPYING ChangeLog
58 %{_libdir}/libXRes.so.1
59 %{_libdir}/libXRes.so.1.0.0
60
61 %files devel
62 %defattr(-,root,root,-)
63 %{_includedir}/X11/extensions/XRes.h
64 %{_libdir}/libXRes.so
65 %{_libdir}/pkgconfig/xres.pc
66 #%dir %{_mandir}/man3x
67 #%{_mandir}/man3/*.3*