upload tizen2.0 source
[framework/uifw/xorg/lib/libxres.git] / packaging / libXres.spec
1 Summary: X-Resource extension client library
2 Name: libXres
3 Version: 1.0.6
4 Release: 1
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig(xext)
12 BuildRequires:  pkgconfig(resourceproto)
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires:  pkgconfig(xproto)
15
16 %description
17 X-Resource is an extension that allows a client to query
18 the X server about its usage of various resources.
19
20 %package devel
21 Summary: Development files for %{name}
22 Group: Development/Libraries
23 Requires: %{name} = %{version}-%{release}
24 Provides: libxres-devel
25
26 %description devel
27 X.Org X11 libXres development package
28
29 %prep
30 %setup -q
31
32 %build
33 %reconfigure --disable-static \
34                LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 make install DESTDIR=$RPM_BUILD_ROOT
41
42 # We intentionally don't ship *.la files
43 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
44
45 %remove_docs
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(-,root,root,-)
55 %doc AUTHORS COPYING ChangeLog
56 %{_libdir}/libXRes.so.1
57 %{_libdir}/libXRes.so.1.0.0
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/X11/extensions/XRes.h
62 %{_libdir}/libXRes.so
63 %{_libdir}/pkgconfig/xres.pc
64 #%dir %{_mandir}/man3x
65 #%{_mandir}/man3/*.3*