upload tizen2.0 source
[framework/uifw/xorg/lib/libxdmcp.git] / packaging / libXdmcp.spec
1 Summary: X Display Manager Control Protocol library
2 Name: libXdmcp
3 Version: 1.1.1
4 Release: 1
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires:  pkgconfig(xproto)
12 BuildRequires:  pkgconfig(xorg-macros)
13
14 %description
15 X Display Manager Control Protocol library.
16
17 %package devel
18 Summary: Development files for %{name}
19 Group: Development/Libraries
20 Provides: libxdmcp-devel 
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24 libXdmcp development package.
25
26 %prep
27 %setup -q
28
29 %build
30 %reconfigure --disable-static \
31            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
38
39 # We intentionally don't ship *.la files
40 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
41
42 # manual fixup later
43 rm -rf $RPM_BUILD_ROOT%{_docdir}
44
45 %remove_docs
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(-,root,root,-)
55 %doc AUTHORS COPYING ChangeLog Wraphelp.README.crypto
56 %{_libdir}/libXdmcp.so.6
57 %{_libdir}/libXdmcp.so.6.0.0
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/X11/Xdmcp.h
62 %{_libdir}/libXdmcp.so
63 %{_libdir}/pkgconfig/xdmcp.pc