upload tizen2.0 source
[framework/uifw/xorg/lib/libice.git] / packaging / libICE.spec
1 Summary: X.Org X11 ICE runtime library
2 Name: libICE
3 Version: 1.0.8
4 Release: 1
5 License: MIT
6 Group: System Environment/Libraries
7 URL: http://www.x.org
8
9 Source0: %{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig
12 BuildRequires:  pkgconfig(xproto)
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-5
15
16 %description
17 The X.Org X11 ICE (Inter-Client Exchange) runtime library.
18
19 %package devel
20 Summary: X.Org X11 ICE development package
21 Group: Development/Libraries
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25 The X.Org X11 ICE (Inter-Client Exchange) development package.
26
27 %prep
28 %setup -q
29
30 %build
31 %reconfigure --disable-static \
32            LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 make install DESTDIR=$RPM_BUILD_ROOT
39
40 # We intentionally don't ship *.la files
41 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
42
43 %remove_docs
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post -p /sbin/ldconfig
49 %postun -p /sbin/ldconfig
50
51 %files
52 %defattr(-,root,root,-)
53 %doc AUTHORS COPYING ChangeLog
54 %{_libdir}/libICE.so.6
55 %{_libdir}/libICE.so.6.3.0
56
57 %files devel
58 %defattr(-,root,root,-)
59 #%{_docdir}/%{name}
60 %{_includedir}/X11/ICE
61 %{_libdir}/libICE.so
62 %{_libdir}/pkgconfig/ice.pc