tizen 2.4 release
[framework/uifw/libeom.git] / packaging / libeom.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name: libeom
5 Summary: External Output Manager Library
6 Version: 1.0.2
7 Release: 1
8 Group: Graphics/X Window System
9 License: MIT
10 Source0: %{name}-%{version}.tar.gz
11 Source1001:     libeom.manifest
12
13 %if %{with wayland}
14 BuildRequires:  pkgconfig(wayland-client)
15 BuildRequires:  pkgconfig(ecore-wayland)
16 %else
17 %endif
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(dbus-1)
20 BuildRequires:  pkgconfig(gio-unix-2.0)
21 BuildRequires:  pkgconfig(capi-base-common)
22 BuildRequires:  pkgconfig(elementary)
23
24 %description
25 This package provides the runtime library to manage eo(External Output)
26
27 %package devel
28 Summary: External Output Manager Library development package
29 Group: Development/Libraries
30 Requires: %{name} = %{version}-%{release}
31 Requires: pkgconfig(capi-base-common)
32
33 %description devel
34 External Output Manager Library development package
35
36 %prep
37 %setup -q
38 cp %{SOURCE1001} .
39
40 %build
41 export CFLAGS="-g -O0 -Wall -Werror -Wno-error=deprecated-declarations"
42 export LDFLAGS="$LDFLAGS -Wl,--hash-style=both -Wl,--as-needed"
43 %if %{with wayland}
44 %reconfigure --disable-dlog --disable-static --with-eom-platform=WAYLAND
45 %else
46 %if 0%{?tizen_version_major} == 2
47 %reconfigure --disable-dlog --disable-static --with-eom-platform=X11 --with-tizen-version=TIZEN_2_X
48 %else
49 %reconfigure --disable-dlog --disable-static --with-eom-platform=X11 --with-tizen-version=TIZEN_3_X
50 %endif
51 %endif
52
53 make %{?_smp_mflags}
54
55 %install
56 rm -rf %{buildroot}
57 mkdir -p %{buildroot}/usr/share/license
58 cp -af COPYING %{buildroot}/usr/share/license/%{name}
59 %make_install
60
61 %remove_docs
62
63 %files
64 %manifest %{name}.manifest
65 %defattr(-,root,root,-)
66 /usr/share/license/%{name}
67 %{_libdir}/libeom.so.*
68
69 %files devel
70 %manifest %{name}.manifest
71 %dir %{_includedir}/eom/
72 %{_includedir}/eom/*.h
73 %{_libdir}/libeom.so
74 %{_libdir}/pkgconfig/eom.pc
75