Remove libisf-bin dependency
[framework/uifw/ise-engine-hangul.git] / scim-hangul.spec
1 %define nam             scim-hangul
2 %define ver             0.3.2
3 %define rel             1
4 %define build_setup     1
5
6 # Something's not quite right with libtool....
7 %define __libtoolize    echo
8
9 Summary:        Hangul Input Method Engine for SCIM
10 Name:           %{nam}
11 Version:        %{ver}
12 Release:        %{rel}
13 License:        GPL
14 Group:          System Environment/Libraries
15 URL:            http://www.freedesktop.org/~suzhe
16 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18 Source0:        %{name}-%{version}.tar.gz
19 #NoSource:      0
20
21 PreReq:         /sbin/ldconfig, /bin/sh
22
23 Requires:       scim >= 0.99.8
24 BuildRequires:  scim-devel >= 0.99.8
25
26 %description
27 SCIM is a developing platform to significant reduce the difficulty of 
28 input method development. 
29
30 %changelog
31 * Sun Jun 13 2004 James Su <suzhe@tsinghua.org.cn>
32 - first release of scim-uim.
33
34 #--------------------------------------------------
35
36 %prep
37
38 %setup -n %{name}-%{version}
39
40 %build
41 %configure --disable-static
42
43 make 
44
45 %install
46 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
47 make DESTDIR=${RPM_BUILD_ROOT} install
48
49 rm -f $RPM_BUILD_ROOT//home/krisna/lib/scim-1.0/1.4.0/IMEngine/hangul.{a,la}
50 rm -f $RPM_BUILD_ROOT//home/krisna/lib/scim-1.0/1.4.0/SetupUI/hangul-imengine-setup.{a,la}
51
52 %clean
53 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-, root, root)
57 %doc AUTHORS COPYING NEWS README ChangeLog
58 /home/krisna/lib/scim-1.0/1.4.0/IMEngine/hangul.so
59 %if %{build_setup}
60 /home/krisna/lib/scim-1.0/1.4.0/SetupUI/hangul-imengine-setup.so
61 %endif
62 %{_datadir}/locale/*/LC_MESSAGES/scim-hangul.mo
63 /home/krisna/share/scim/icons/scim-hangul.png