tizen 2.3.1 release
[framework/uifw/embryo.git] / packaging / embryo.spec
1 Name:       embryo
2 Summary:    A small virtual machine engine (in a library) and bytecode compiler
3 Version:    1.6.0+svn.76491slp2+build07
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD 2-Clause
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires: pkgconfig(eina)
12
13
14 %description
15 Development files for libembryo0 Embryo is primarily a shared library that gives you an API to load
16  and control interpreted programs compiled into an abstract machine
17  bytecode that it understands.  This abstract (or virtual) machine is
18  similar to a real machine with a CPU, but it is emulated in
19  software.
20  This packages contains headers and static libraries for Embryo.
21
22
23 %package devel
24 Summary:    A small virtual machine engine and bytecode compile (devel)
25 Group:      Development/Libraries
26 Requires:   %{name} = %{version}-%{release}
27
28
29 %description devel
30 A small virtual machine engine (in a library) and bytecode compile (devel)
31
32
33 %package tools
34 Summary:    A small virtual machine engine and bytecode compile (tools)
35 Group:      Development/Tools
36 Requires:   %{name} = %{version}-%{release}
37 Provides:   %{name}-bin
38 Obsoletes:  %{name}-bin
39
40
41 %description tools
42 A small virtual machine engine (in a library) and bytecode compile (tools)
43
44
45 %prep
46 %setup -q
47
48
49 %build
50 export CFLAGS+=" -fvisibility=hidden -fPIC -Wall"
51 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
52
53 %autogen --disable-static
54 make %{?jobs:-j%jobs}
55
56 %install
57 %make_install
58 mkdir -p %{buildroot}/%{_datadir}/license
59 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{_datadir}/license/%{name}
60 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{_datadir}/license/%{name}-tools
61
62 %post -p /sbin/ldconfig
63
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(-,root,root,-)
68 %{_libdir}/libembryo.so.*
69 %{_datadir}/license/%{name}
70 %manifest %{name}.manifest
71
72
73 %files devel
74 %defattr(-,root,root,-)
75 %{_includedir}/embryo-1/Embryo.h
76 %{_libdir}/libembryo.so
77 %{_libdir}/pkgconfig/*.pc
78
79
80 %files tools
81 %defattr(-,root,root,-)
82 %{_bindir}/embryo_cc
83 %{_datadir}/license/%{name}-tools
84 %{_datadir}/embryo/include/default.inc