Tizen 2.0 Release
[framework/uifw/embryo.git] / packaging / embryo.spec
1 #sbs-git:slp/pkgs/e/embryo embryo 1.1.0+svn.68928slp2+build01 ff312ab0f1dd243c5f94e56b2e55f3c43b0cf40f
2 Name:       embryo
3 Summary:    A small virtual machine engine (in a library) and bytecode compiler
4 Version:    1.7.1+svn.76491slp2+build01
5 Release:    1
6 Group:      System/Libraries
7 License:    BSD
8 URL:        http://www.enlightenment.org/
9 Source0:    %{name}-%{version}.tar.gz
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires: pkgconfig(eina)
13 Provides: embryo-bin
14
15
16 %description
17 Development files for libembryo0 Embryo is primarily a shared library that gives you an API to load
18  and control interpreted programs compiled into an abstract machine
19  bytecode that it understands.  This abstract (or virtual) machine is
20  similar to a real machine with a CPU, but it is emulated in
21  software.
22  .
23  This packages contains headers and static libraries for Embryo.
24
25
26
27 %package devel
28 Summary:    A small virtual machine engine and bytecode compile (devel)
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 A small virtual machine engine (in a library) and bytecode compile (devel)
34
35 %prep
36 %setup -q
37
38
39 %build
40 export CFLAGS+=" -fvisibility=hidden -fPIC"
41 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
42
43 %autogen --disable-static
44 %configure --disable-static
45 make %{?jobs:-j%jobs}
46
47 %install
48 %make_install
49 mkdir -p %{buildroot}/usr/share/license
50 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
51
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56 %files
57 %defattr(-,root,root,-)
58 %{_libdir}/libembryo.so.*
59 %{_bindir}/embryo_cc
60 %{_datadir}/embryo/include/default.inc
61 /usr/share/license/%{name}
62 %manifest %{name}.manifest
63
64 %files devel
65 %defattr(-,root,root,-)
66 %{_includedir}/embryo-1/Embryo.h
67 %{_libdir}/libembryo.so
68 %{_libdir}/pkgconfig/*.pc