Add RPM packaging
[framework/uifw/embryo.git] / packaging / embryo.spec
1
2 # Do NOT Edit the Auto-generated Part!
3 # Generated by: spectacle version 0.22
4
5
6 Name:       embryo
7 Summary:    A small virtual machine engine (in a library) and bytecode compiler
8 Version:    1.0.999.svn60294
9 Release:    1
10 Group:      TO_BE/FILLED_IN
11 License:    TO BE FILLED IN
12 URL:        http://www.enlightenment.org/
13 Source0:    http://download.enlightenment.org/releases/embryo-%{version}.tar.bz2
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 BuildRequires: pkgconfig(eina)
17 #BuildRequires:  doxygen
18
19
20 %description
21 Development files for libembryo0 Embryo is primarily a shared library that gives you an API to load
22  and control interpreted programs compiled into an abstract machine
23  bytecode that it understands.  This abstract (or virtual) machine is
24  similar to a real machine with a CPU, but it is emulated in
25  software.
26  .
27  This packages contains headers and static libraries for Embryo.
28
29
30
31 %package devel
32 Summary:    A small virtual machine engine and bytecode compile (devel)
33 Group:      Development/Libraries
34 Requires:   %{name} = %{version}-%{release}
35
36 %description devel
37 A small virtual machine engine (in a library) and bytecode compile (devel)
38
39 %package bin
40 Summary:    A small virtual machine engine and bytecode compile (bin)
41 Group:      Development/Libraries
42 Requires:   %{name} = %{version}-%{release}
43
44 %description bin
45 A small virtual machine engine (in a library) and bytecode compile (bin)
46
47
48 %prep
49 %setup -q -n %{name}
50
51
52 %build
53
54 %autogen --disable-static
55 %configure --disable-static
56 make %{?jobs:-j%jobs}
57
58 %install
59 rm -rf %{buildroot}
60 %make_install
61
62
63
64
65 %post -p /sbin/ldconfig
66
67 %postun -p /sbin/ldconfig
68
69
70
71
72
73
74
75
76 %files
77 %defattr(-,root,root,-)
78 %{_libdir}/libembryo.so.*
79
80
81 %files devel
82 %defattr(-,root,root,-)
83 %{_includedir}/embryo-1/Embryo.h
84 %{_libdir}/libembryo.so
85 %{_libdir}/pkgconfig/*.pc
86
87 %files bin
88 %defattr(-,root,root,-)
89 /usr/bin/embryo_cc
90 /usr/share/embryo/include/default.inc
91