fix .spec for rpm packaging
[framework/uifw/eet.git] / packaging / eet.spec
1 Name:       eet
2 Summary:    Library for speedy data storage, retrieval, and compression
3 Version:    1.4.999.svn60246
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 URL:        http://www.enlightenment.org/
8 Source0:    http://download.enlightenment.org/releases/eet-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(eina)
12 BuildRequires:  pkgconfig(gnutls)
13 BuildRequires:  pkgconfig(openssl)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  libjpeg-devel
16
17
18 %description
19 Enlightenment DR17 file chunk reading/writing library development files Eet is a tiny library designed to write an arbitary set of chunks of data to a
20  file and optionally compress each chunk (very much like a zip file) and allow
21  fast random-access reading of the file later on. It does not do zip as zip
22  itself has more complexity than we need, and it was much simpler to implement
23  this once here.
24  .
25  This package contains headers and static libraries for development with libeet.
26
27
28
29 %package devel
30 Summary:    Library for speedy data storage, retrieval, and compression (devel)
31 Group:      Development/Libraries
32 Requires:   %{name} = %{version}-%{release}
33
34 %description devel
35 Enlightenment DR17 file chunk reading/writing library  (devel)
36
37 %package bin
38 Summary:    Library for speedy data storage, retrieval, and compression. (bin)
39 Group:      Development/Libraries
40 Requires:   %{name} = %{version}-%{release}
41
42 %description bin
43 Enlightenment DR17 file chunk reading/writing library  (bin)
44
45
46 %prep
47 %setup -q -n %{name}
48
49
50 %build
51
52 %autogen --disable-static
53 %configure --disable-static \
54     --disable-openssl --disable-cypher --disable-signature --disable-gnutls
55
56 make %{?jobs:-j%jobs}
57
58 %install
59 rm -rf %{buildroot}
60 %make_install
61
62
63
64
65 %post -p /sbin/ldconfig
66
67 %postun -p /sbin/ldconfig
68
69
70 %files
71 %defattr(-,root,root,-)
72 %{_libdir}/*.so.*
73
74
75 %files devel
76 %defattr(-,root,root,-)
77 %{_includedir}/*
78 %{_libdir}/*.so
79 %{_libdir}/pkgconfig/eet.pc
80
81 %files bin
82 %defattr(-,root,root,-)
83 /usr/bin/*
84