Add RPM packaging
[framework/uifw/eet.git] / packaging / eet.spec
1 Name:       eet
2 Summary:    Library for speedy data storage, retrieval, and compression
3 Version:    1.4.999.svn60246
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 URL:        http://www.enlightenment.org/
8 Source0:    http://download.enlightenment.org/releases/eet-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(eina)
12 BuildRequires:  pkgconfig(gnutls)
13 BuildRequires:  pkgconfig(openssl)
14 BuildRequires:  libjpeg-devel
15
16
17 %description
18 Enlightenment DR17 file chunk reading/writing library development files Eet is a tiny library designed to write an arbitary set of chunks of data to a
19  file and optionally compress each chunk (very much like a zip file) and allow
20  fast random-access reading of the file later on. It does not do zip as zip
21  itself has more complexity than we need, and it was much simpler to implement
22  this once here.
23  .
24  This package contains headers and static libraries for development with libeet.
25
26
27
28 %package devel
29 Summary:    Library for speedy data storage, retrieval, and compression (devel)
30 Group:      Development/Libraries
31 Requires:   %{name} = %{version}-%{release}
32
33 %description devel
34 Enlightenment DR17 file chunk reading/writing library  (devel)
35
36 %package bin
37 Summary:    Library for speedy data storage, retrieval, and compression. (bin)
38 Group:      Development/Libraries
39 Requires:   %{name} = %{version}-%{release}
40
41 %description bin
42 Enlightenment DR17 file chunk reading/writing library  (bin)
43
44
45 %prep
46 %setup -q -n %{name}
47
48
49 %build
50
51 %autogen --disable-static
52 %configure --disable-static \
53     --disable-openssl --disable-cypher --disable-signature --disable-gnutls
54
55 make %{?jobs:-j%jobs}
56
57 %install
58 rm -rf %{buildroot}
59 %make_install
60
61
62
63
64 %post -p /sbin/ldconfig
65
66 %postun -p /sbin/ldconfig
67
68
69
70
71
72
73
74
75 %files
76 %defattr(-,root,root,-)
77 %{_libdir}/libeet.so.*
78
79
80 %files devel
81 %defattr(-,root,root,-)
82 %{_includedir}/eet-1/Eet.h
83 %{_libdir}/libeet.so
84 %{_libdir}/pkgconfig/eet.pc
85
86 %files bin
87 %defattr(-,root,root,-)
88 /usr/bin/eet
89