Package upload
[framework/uifw/eet.git] / packaging / eet.spec
1 Name:       eet
2 Summary:    Library for speedy data storage, retrieval, and compression
3 Version:    1.6.0+svn.70308slp2+build01
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(eina)
12 BuildRequires:  pkgconfig(gnutls)
13 BuildRequires:  pkgconfig(openssl)
14 BuildRequires:  pkgconfig(zlib)
15 BuildRequires:  libjpeg-devel
16
17
18 %description
19 Enlightenment DR17 file chunk reading/writing library development files Eet is a tiny library designed to write an arbitary set of chunks of data to a
20  file and optionally compress each chunk (very much like a zip file) and allow
21  fast random-access reading of the file later on. It does not do zip as zip
22  itself has more complexity than we need, and it was much simpler to implement
23  this once here.
24  .
25  This package contains headers and static libraries for development with libeet.
26
27
28 %package devel
29 Summary:    Library for speedy data storage, retrieval, and compression (devel)
30 Group:      Development/Libraries
31 Requires:   %{name} = %{version}-%{release}
32
33
34 %description devel
35 Enlightenment DR17 file chunk reading/writing library  (devel)
36
37
38 %package tools
39 Summary:    Library for speedy data storage, retrieval, and compression. (tools)
40 Group:      Development/Libraries
41 Requires:   %{name} = %{version}-%{release}
42 Provides:   %{name}-bin
43 Obsoletes:  %{name}-bin
44
45
46 %description tools
47 Enlightenment DR17 file chunk reading/writing library  (tools)
48
49
50 %prep
51 %setup -q
52
53
54 %build
55 export CFLAGS+=" -fvisibility=hidden -fPIC"
56 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
57
58 %autogen --disable-static
59 %configure --disable-static \
60     --disable-openssl --disable-cypher --disable-signature --disable-gnutls
61
62 make %{?jobs:-j%jobs}
63
64
65 %install
66 rm -rf %{buildroot}
67 %make_install
68
69
70 %post -p /sbin/ldconfig
71
72
73 %postun -p /sbin/ldconfig
74
75
76 %files
77 %defattr(-,root,root,-)
78 %{_libdir}/libeet.so.*
79
80
81 %files devel
82 %defattr(-,root,root,-)
83 %{_includedir}/*
84 %{_libdir}/*.so
85 %{_libdir}/pkgconfig/eet.pc
86
87
88 %files tools
89 %defattr(-,root,root,-)
90 %{_bindir}/*
91 %{_datadir}/eet/examples/eet-basic.c
92 %{_datadir}/eet/examples/eet-data-cipher_decipher.c
93 %{_datadir}/eet/examples/eet-data-file_descriptor_01.c
94 %{_datadir}/eet/examples/eet-data-file_descriptor_02.c
95 %{_datadir}/eet/examples/eet-data-nested.c
96 %{_datadir}/eet/examples/eet-data-simple.c
97 %{_datadir}/eet/examples/eet-file.c
98