Package Upload
[framework/uifw/eet.git] / packaging / eet.spec
1 Name:       eet
2 Summary:    Library for speedy data storage, retrieval, and compression
3 Version:    1.6.0+svn.74530slp2+build01
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  eina-devel
12 BuildRequires:  gnutls-devel
13 BuildRequires:  zlib-devel
14 BuildRequires:  libjpeg-devel
15
16
17 %description
18 Enlightenment DR17 file chunk reading/writing library development files Eet is a tiny library designed to write an arbitary set of chunks of data to a
19  file and optionally compress each chunk (very much like a zip file) and allow
20  fast random-access reading of the file later on. It does not do zip as zip
21  itself has more complexity than we need, and it was much simpler to implement
22  this once here.
23  .
24  This package contains headers and static libraries for development with libeet.
25
26
27 %package devel
28 Summary:    Library for speedy data storage, retrieval, and compression (devel)
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32
33 %description devel
34 Enlightenment DR17 file chunk reading/writing library  (devel)
35
36
37 %package tools
38 Summary:    Library for speedy data storage, retrieval, and compression. (tools)
39 Group:      Development/Libraries
40 Requires:   %{name} = %{version}-%{release}
41 Provides:   %{name}-bin
42 Obsoletes:  %{name}-bin
43
44
45 %description tools
46 Enlightenment DR17 file chunk reading/writing library  (tools)
47
48
49 %prep
50 %setup -q
51
52
53 %build
54 export CFLAGS+=" -fvisibility=hidden -fPIC"
55 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
56
57 %autogen --disable-static
58 %configure --disable-static \
59     --disable-openssl --disable-cypher --disable-signature --disable-gnutls
60
61 make %{?jobs:-j%jobs}
62
63
64 %install
65 rm -rf %{buildroot}
66 %make_install
67
68
69 %post -p /sbin/ldconfig
70
71
72 %postun -p /sbin/ldconfig
73
74
75 %files
76 %defattr(-,root,root,-)
77 %{_libdir}/libeet.so.*
78
79
80 %files devel
81 %defattr(-,root,root,-)
82 %{_includedir}/*
83 %{_libdir}/*.so
84 %{_libdir}/pkgconfig/eet.pc
85
86
87 %files tools
88 %defattr(-,root,root,-)
89 %{_bindir}/*
90 %{_datadir}/eet/examples/eet-basic.c
91 %{_datadir}/eet/examples/eet-data-cipher_decipher.c
92 %{_datadir}/eet/examples/eet-data-file_descriptor_01.c
93 %{_datadir}/eet/examples/eet-data-file_descriptor_02.c
94 %{_datadir}/eet/examples/eet-data-nested.c
95 %{_datadir}/eet/examples/eet-data-simple.c
96 %{_datadir}/eet/examples/eet-file.c
97