remove chip status in gyro sensor plugin
[framework/system/sensor-plugins.git] / packaging / sensor-plugins.spec
1 Name:       sensor-plugins
2 Summary:    Sensor plugins
3 Version:    0.0.5
4 Release:    1
5 ExclusiveArch:  %arm   
6 Group:      misc
7 License:    samsung
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10
11 %description
12 Sensor plugins
13
14 %prep
15 %setup -q
16
17 %build
18 cmake . -DCMAKE_INSTALL_PREFIX=/usr/lib/sensor-framework
19 make %{?jobs:-j%jobs}
20
21 %install
22 %make_install
23
24 %files
25 %attr(0644,root,root)/usr/lib/sensor_framework/libak8963cl.so
26 %attr(0644,root,root)/usr/lib/sensor_framework/libak8963cl_processor.so
27 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975.so
28 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975_filter.so
29 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975_processor.so
30 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975ck.so
31 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975ck_processor.so
32 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975cl.so
33 %attr(0644,root,root)/usr/lib/sensor_framework/libak8975cl_processor.so
34 %attr(0644,root,root)/usr/lib/sensor_framework/libbma023.so
35 %attr(0644,root,root)/usr/lib/sensor_framework/libbma023_filter.so
36 %attr(0644,root,root)/usr/lib/sensor_framework/libbma023_processor.so
37 %attr(0644,root,root)/usr/lib/sensor_framework/libbma254.so
38 %attr(0644,root,root)/usr/lib/sensor_framework/libbma254_processor.so
39 %attr(0644,root,root)/usr/lib/sensor_framework/libcm3623ambi.so
40 %attr(0644,root,root)/usr/lib/sensor_framework/libcm3623ambi_filter.so
41 %attr(0644,root,root)/usr/lib/sensor_framework/libcm3623ambi_processor.so
42 %attr(0644,root,root)/usr/lib/sensor_framework/libcm3623proxi.so
43 %attr(0644,root,root)/usr/lib/sensor_framework/libcm3623proxi_filter.so
44 %attr(0644,root,root)/usr/lib/sensor_framework/libcm3623proxi_processor.so
45 %attr(0644,root,root)/usr/lib/sensor_framework/libcm36651ambi.so
46 %attr(0644,root,root)/usr/lib/sensor_framework/libcm36651ambi_processor.so
47 %attr(0644,root,root)/usr/lib/sensor_framework/libcm36651proxi.so
48 %attr(0644,root,root)/usr/lib/sensor_framework/libcm36651proxi_processor.so
49 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap002ambi.so
50 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap002ambi_filter.so
51 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap002ambi_processor.so
52 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap002proxi.so
53 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap002proxi_filter.so
54 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap002proxi_processor.so
55 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap020ambi.so
56 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap020ambi_processor.so
57 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap020proxi.so
58 %attr(0644,root,root)/usr/lib/sensor_framework/libgp2ap020proxi_processor.so
59 %attr(0644,root,root)/usr/lib/sensor_framework/libkr3dm.so
60 %attr(0644,root,root)/usr/lib/sensor_framework/libkr3dm_processor.so
61 %attr(0644,root,root)/usr/lib/sensor_framework/libl3g4200d.so
62 %attr(0644,root,root)/usr/lib/sensor_framework/libl3g4200d_processor.so
63 %attr(0644,root,root)/usr/lib/sensor_framework/liblps331ap.so
64 %attr(0644,root,root)/usr/lib/sensor_framework/liblps331ap_processor.so
65 %attr(0644,root,root)/usr/lib/sensor_framework/liblsm330dlc_accel.so
66 %attr(0644,root,root)/usr/lib/sensor_framework/liblsm330dlc_accel_processor.so
67 %attr(0644,root,root)/usr/lib/sensor_framework/liblsm330dlc_gyro.so
68 %attr(0644,root,root)/usr/lib/sensor_framework/liblsm330dlc_gyro_processor.so
69 %attr(0644,root,root)/usr/lib/sensor_framework/libmotion_filter.so
70 %attr(0644,root,root)/usr/lib/sensor_framework/libmotion_processor.so
71