fix gbs/obs build failure
[framework/osp/social.git] / packaging / osp-social.spec
1 %define __strip /bin/true
2
3 Name:           osp-social
4 Summary:        osp social library
5 Version:        1.2.1.7
6 Release:        6
7 Group:          System/Libraries
8 License:        Apache License, Version 2.0
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(contacts-service2)
12 BuildRequires:  pkgconfig(calendar-service2)
13 BuildRequires:  pkgconfig(accounts-svc)
14 BuildRequires:  pkgconfig(libwbxml2)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(db-util)
17 BuildRequires:  pkgconfig(osp-appfw)
18 BuildRequires:  osp-appfw-internal-devel
19 BuildRequires:  pkgconfig(osp-uifw)
20 BuildRequires:  osp-uifw-internal-devel
21 BuildRequires:  pkgconfig(osp-image)
22 BuildRequires:  osp-image-internal-devel
23 BuildRequires:  pkgconfig(osp-image-core)
24 BuildRequires:  osp-image-core-internal-devel
25
26 # runtime requires
27 Requires: osp-appfw 
28 Requires: osp-image
29
30 %description
31 osp social library
32
33 %package devel
34 Summary:    osp social library (Development)
35 Group:      TO_BE/FILLED_IN
36 Requires:   %{name} = %{version}-%{release}
37
38 %description devel
39 osp social library (DEV)
40
41 %package internal-devel
42 Summary:    osp social library (Internal)
43 Group:      TO_BE/FILLED_IN
44 Requires:   %{name} = %{version}-%{release}
45
46 %description internal-devel
47 osp social library (Internal-DEV)
48
49 %package debug
50 Summary:    osp social library (Development)
51 Group:      TO_BE/FILLED_IN
52 Requires:   %{name} = %{version}-%{release}
53
54 %description debug
55 osp social library (DEV)
56
57 %prep
58 %setup -q
59
60 %build 
61 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
62 %ifarch %{ix86}
63 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
64 %else
65 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=arm
66 %endif
67
68 # Call make instruction with smp support
69 make %{?jobs:-j%jobs}
70
71 %install
72 rm -rf %{buildroot}
73 mkdir -p %{buildroot}/usr/share/license
74 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
75
76 %make_install
77
78 %post -p /sbin/ldconfig
79
80 %postun -p /sbin/ldconfig
81
82 %files
83 %manifest osp-social.manifest
84 /usr/share/license/%{name}
85 %{_libdir}/osp/*.so*
86 /usr/etc/package-manager/parserlib/libaccount.so
87
88 %files devel
89 %{_includedir}/osp/*.h
90 %{_libdir}/pkgconfig/osp-social.pc
91
92 %files internal-devel
93 %{_includedir}/osp/social/*.h
94
95 %files debug
96 %{_libdir}/osp/debug/*.so*